In the package definition the call to the command 'git' is substituted with
the full path to the git executable. This change causes the mix formatting tool
to complain that the line is too long. This workaround reformats the file
after the substitution is made.
--- a/Makefile
+++ b/Makefile
@@ -265,6 +265,7 @@ format: compile
$(call FORMAT)
test_formatted: compile
+ $(call FORMAT,lib/mix/lib/mix/scm/git.ex)
$(call FORMAT,--check-formatted)
test_erlang: compile $(TEST_ERLS)
'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2016-02-21 | gnu: Don't use python-enum34 when building with python-3.4....* gnu/packages/docker.scm (docker-compose)[inputs]: Remove python-enum34.
* gnu/packages/python.scm (python-parse-type)[inputs]: Likewise.
(behave)[inputs]: Likewise.
(python-cryptography)[propagated-inputs]: Likewise.
(python2-cryptography)[propagated-inputs]: Add python2-enum34.
| Leo Famulari |
2016-01-14 | gnu: Add docker-compose....* gnu/packages/docker.scm (docker-compose): New variable.
| David Thompson |
2016-01-14 | gnu: Add python-dockerpty....* gnu/packages/docker.scm (python-dockerpty): New variable.
| David Thompson |
2016-01-14 | gnu: Add python-docker-py....* gnu/packages/docker.scm: New file.
* Makefile.am (GNU_SYSTEM_MODULES): Add it.
| David Thompson |