Patch adapted from Sage. Allows building ECL on libffi 3.3.
diff --git a/src/c/ffi.d b/src/c/ffi.d
index 8861303e..8a959c23 100644
--- a/src/c/ffi.d
+++ b/src/c/ffi.d
@@ -133,8 +133,8 @@ static struct {
#elif defined(X86_WIN64)
{@':win64', FFI_WIN64},
#elif defined(X86_ANY) || defined(X86) || defined(X86_64)
- {@':cdecl', FFI_SYSV},
- {@':sysv', FFI_SYSV},
+ {@':cdecl', FFI_UNIX64},
+ {@':sysv', FFI_UNIX64},
{@':unix64', FFI_UNIX64},
#endif
};
static/cgit.png' alt='cgit logo'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-10-01 | gnu: xfig: Update to 3.2.9....* gnu/packages/patches/xfig-Enable-error-message-for-missing-libraries.patch:
New file.
* gnu/packages/patches/xfig-Fix-double-free-when-requesting-MediaBox.patch:
Likewise.
* gnu/packages/patches/xfig-Use-pkg-config-to-set-fontconfig-CFLAGS-and-LIBS.patch:
Likewise.
* gnu/local.mk (dist_patch_DATA): Register new patches.
* gnu/packages/xfig.scm (xfig): Update to 3.2.9.
[source]: Use new patches.
[arguments]<#:phases>: Add ‘wrap-program’.
[native-inputs]: Add pkg-config, autoconf, automake and libtool.
Move ghostscript to …
[inputs]: … here. Add fig2dev, libxaw3d and libxft.
[license]: Update URL.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| Bruno Victal |
2023-10-01 | gnu: Add fig2dev....The source used by the transfig package is outdated and its development
was moved into the repository used by fig2dev though the utility
`transfig' is considered obsolete and not built by default in the
fig2dev package. In practice, this is not a problem since the user is
generally after the `fig2dev' utility which was also provided in the
(now obsolete) transfig package.
Descriptions and comments pointing to the now obsolete packages are
adjusted accordingly. For texlive-latex-make, this follow upstream at
<https://gitlab.inria.fr/latex-utils/latex-make/-/commit/1dcc04aaa860b123924ae83fc30a47d6f7179f7a>.
* gnu/packages/xfig.scm: Import all of (guix licenses).
(xfig)[license]: Adjust accordingly.
(fig2dev): New variable.
(transfig): Deprecate in favor of fig2dev.
* gnu/packages/patches/transfig-gcc10-fno-common.patch: Removed file.
* gnu/local.mk (dist_patch_DATA): Unregister it.
* gnu/packages/docbook.scm (dblatex): Update comment.
* gnu/packages/tex.scm (texlive-latex-make)[description]: Update description.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| Bruno Victal |
2023-10-01 | gnu: xfig: Use G-Expressions....* gnu/packages/xfig.scm (xfig)[arguments]<#:phases>: Relocate
'strip-bogus-exec-prefix into …
[sources]: … here, as a snippet instead.
[inputs]: Restyle.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| Bruno Victal |