Patch adapted from Sage. diff -Naur ecl-16.1.2.orig/src/c/file.d ecl-16.1.2/src/c/file.d --- ecl-16.1.2.orig/src/c/file.d 2016-05-11 13:10:51.867673867 +1200 +++ ecl-16.1.2/src/c/file.d 2016-05-11 14:44:48.121907307 +1200 @@ -3354,8 +3354,10 @@ ecl_disable_interrupts(); do { out = fwrite(c, sizeof(char), n, IO_STREAM_FILE(strm)); - } while (out < n && restartable_io_error(strm, "fwrite")); - ecl_enable_interrupts(); + /* Ignore write errors to stderr to avoid an infinite loop */ + } while (out < n && (IO_STREAM_FILE(strm) != stderr) && restartable_io_error(strm, "fwrite")); + + ecl_enable_interrupts(); return out; } 800664'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/nix.scm
AgeCommit message (Expand)Author
2020-07-25services: nix: Add extra-options....Oleg Pykhalov
2020-07-25services: nix: Fix typo....Oleg Pykhalov
2020-07-25services: nix: Export nix-configuration....Peng Mei Yu
2020-07-25services: nix: Provide nix commands....Peng Mei Yu via Guix-patches via
2020-07-22services: nix: Fix sandbox....Oleg Pykhalov
2020-06-25services: Add missing (ice-9 format) import....Ludovic Courtès
2019-06-12services: Import (srfi srfi-26) from the build side....Tobias Geerinckx-Rice
2019-06-11services: Add SRFI-26 to Nix activation gexp....Tobias Geerinckx-Rice
2019-06-10services: Add 'nix-service-type'....Oleg Pykhalov