diff -up dovecot-2.3.14/src/lib-dcrypt/dcrypt-openssl.c.opensslv3 dovecot-2.3.14/src/lib-dcrypt/dcrypt-openssl.c --- dovecot-2.3.14/src/lib-dcrypt/dcrypt-openssl.c.opensslv3 2021-06-03 18:56:52.573174433 +0200 +++ dovecot-2.3.14/src/lib-dcrypt/dcrypt-openssl.c 2021-06-03 18:56:52.585174274 +0200 @@ -73,10 +73,30 @@ 2key algo oid1symmetric algo namesalthash algoroundsE(RSA = i2d_PrivateKey, EC=Private Point)key id **/ +#if OPENSSL_VERSION_MAJOR == 3 +static EC_KEY *EVP_PKEY_get0_EC_KEYv3(EVP_PKEY *key) +{ + EC_KEY *eck = EVP_PKEY_get1_EC_KEY(key); + EVP_PKEY_set1_EC_KEY(key, eck); + EC_KEY_free(eck); + return eck; +} + +static EC_KEY *EVP_PKEY_get1_EC_KEYv3(EVP_PKEY *key) +{ + EC_KEY *eck = EVP_PKEY_get1_EC_KEY(key); + EVP_PKEY_set1_EC_KEY(key, eck); + return eck; +} + +#define EVP_PKEY_get0_EC_KEY EVP_PKEY_get0_EC_KEYv3 +#define EVP_PKEY_get1_EC_KEY EVP_PKEY_get1_EC_KEYv3 +#else #ifndef HAVE_EVP_PKEY_get0 #define EVP_PKEY_get0_EC_KEY(x) x->pkey.ec #define EVP_PKEY_get0_RSA(x) x->pkey.rsa #endif +#endif #ifndef HAVE_OBJ_LENGTH #define OBJ_length(o) ((o)->length) >refslogtreecommitdiff
AgeCommit message (Expand)Author
2021-09-28tests: go: Fix typo....Tobias Geerinckx-Rice
2021-09-01import: go: Improve error handling....zimoun
2021-07-18import: go: Upgrade go.mod parser....Sarah Morgensen
2021-07-17tests/go: Remove unused variable....Maxim Cournoyer
2021-05-05tests: go: Remove duplicate go-version->git-ref test....Maxim Cournoyer
2021-05-04tests: go: Fix typos in test descriptions....Tobias Geerinckx-Rice
2021-04-09import: go: Add an option to use pinned versions....Maxim Cournoyer
2021-04-09import: go: Improve synopsis and description parsing....Maxim Cournoyer
2021-03-10import: go: Compute the hash of Git checkouts....Ludovic Courtès
2021-03-10import: Add Go importer....Katherine Cox-Buday