Author: Danny Milosavljevic The socket name ended up too long inside the container. Use a shorter one. --- a/pkg/authorization/authz_unix_test.go 2019-01-10 01:55:02.997985947 +0100 +++ b/pkg/authorization/authz_unix_test.go 2019-01-10 02:03:21.177439757 +0100 @@ -24,7 +24,7 @@ ) const ( - pluginAddress = "authz-test-plugin.sock" + pluginAddress = "/tmp/authz-test-plugin.sock" ) func TestAuthZRequestPluginError(t *testing.T) { @@ -263,12 +263,7 @@ // createTestPlugin creates a new sample authorization plugin func createTestPlugin(t *testing.T) *authorizationPlugin { - pwd, err := os.Getwd() - if err != nil { - t.Fatal(err) - } - - client, err := plugins.NewClient("unix:///"+path.Join(pwd, pluginAddress), &tlsconfig.Options{InsecureSkipVerify: true}) + client, err := plugins.NewClient("unix:///"+path.Join("/", pluginAddress), &tlsconfig.Options{InsecureSkipVerify: true}) if err != nil { t.Fatalf("Failed to create client %v", err) } ight'>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
AgeCommit message (Expand)Author
2018-03-17gnu: python-protobuf: Update to 3.5.2....Tobias Geerinckx-Rice
2017-12-23gnu: protobuf: Update to 3.5.1....Tobias Geerinckx-Rice
2017-12-04gnu: protobuf: Update to 3.5.0....Tobias Geerinckx-Rice
2017-11-21gnu: Use ‘license:’ prefix in (gnu packages protobuf)....Tobias Geerinckx-Rice
2017-11-21gnu: Add fstrm....Tobias Geerinckx-Rice
2017-11-21gnu: protobuf: Add ‘static’ output....Tobias Geerinckx-Rice
2017-10-20gnu: ola: Build with protobuf@2....Tobias Geerinckx-Rice
2017-10-18gnu: python-protobuf: Update to 3.4.0....Ricardo Wurmus
2017-10-18gnu: Add protobuf-c....Ricardo Wurmus
2017-10-18gnu: protobuf: Update to 3.4.1....Ricardo Wurmus