Author: Danny Milosavljevic The socket name ended up too long inside the container. Use a shorter one. --- a/pkg/authorization/authz_unix_test.go 2019-01-10 01:55:02.997985947 +0100 +++ b/pkg/authorization/authz_unix_test.go 2019-01-10 02:03:21.177439757 +0100 @@ -24,7 +24,7 @@ ) const ( - pluginAddress = "authz-test-plugin.sock" + pluginAddress = "/tmp/authz-test-plugin.sock" ) func TestAuthZRequestPluginError(t *testing.T) { @@ -263,12 +263,7 @@ // createTestPlugin creates a new sample authorization plugin func createTestPlugin(t *testing.T) *authorizationPlugin { - pwd, err := os.Getwd() - if err != nil { - t.Fatal(err) - } - - client, err := plugins.NewClient("unix:///"+path.Join(pwd, pluginAddress), &tlsconfig.Options{InsecureSkipVerify: true}) + client, err := plugins.NewClient("unix:///"+path.Join("/", pluginAddress), &tlsconfig.Options{InsecureSkipVerify: true}) if err != nil { t.Fatalf("Failed to create client %v", err) }
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests.scm
AgeCommit message (Expand)Author
2020-07-25utils: Move <location> and '&error-location' to (guix diagnostics)....Ludovic Courtès
2020-03-05tests: Add <system-test> gexp compiler....Ludovic Courtès
2020-01-23tests: Fix typo in comment....Ludovic Courtès
2019-12-18gexp: Allow character literals in GEXP->SEXP....Marius Bakke
2019-09-23repl, marionette: 'self-quoting?' matches keywords....Ludovic Courtès
2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....Ludovic Courtès
2018-08-29tests: Warn about test module load failures....Ludovic Courtès
2018-05-28system: Remove uses of the 'title' field of <file-system>....Ludovic Courtès