Fix CVE-2009-3994 (buffer overflow in GetUID() allows remote DOS or
arbitrary code execution via crafted DICOM file).
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3994
Copied from Fedora
https://pkgs.fedoraproject.org/cgit/rpms/DevIL.git/tree/DevIL-1.7.8-CVE-2009-3994.patch?id=9c656a75393d6c455aef9f4968fbbee9c53f4fdb
diff -up devil-1.7.8/src-IL/src/il_dicom.c~ devil-1.7.8/src-IL/src/il_dicom.c
--- devil-1.7.8/src-IL/src/il_dicom.c~ 2009-03-08 08:10:09.000000000 +0100
+++ devil-1.7.8/src-IL/src/il_dicom.c 2009-12-03 12:07:45.000000000 +0100
@@ -427,9 +427,11 @@ ILboolean GetUID(ILubyte *UID)
return IL_FALSE;
ValLen = GetLittleUShort();
+ if (ValLen > 64)
+ return IL_FALSE;
if (iread(UID, ValLen, 1) != 1)
return IL_FALSE;
- UID[64] = 0; // Just to make sure that our string is terminated.
+ UID[ValLen] = 0; // Just to make sure that our string is terminated.
return IL_TRUE;
}
>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-01-18 | gnu: easyrpg-player: Update to 0.7.0....* gnu/packages/easyrpg.scm (easyrpg-player): Update to 0.7.0.
[inputs]: Add fluidsynth, fmt.
| Nicolas Goaziou |
2022-01-18 | gnu: liblcf: Update to 0.7.0....* gnu/packages/easyrpg.scm (liblcf): Update to 0.7.0.
| Nicolas Goaziou |
2021-12-13 | gnu: Further simplify package inputs....This is the result of running:
./pre-inst-env guix style --input-simplification=safe
and manually undoing changes on a dozen of packages to reduce
rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
| Ludovic Courtès |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-09-18 | gnu: easyrpg-player: Add wildmidi input....Suggested by moshy on #guix.
* gnu/packages/easyrpg.scm (easyrpg-player)[inputs]: Add wildmidi.
| Tobias Geerinckx-Rice |