From e1f7039f1b06add4fb75b2f8774000b8f05574af Mon Sep 17 00:00:00 2001 From: rogerman Date: Mon, 17 Aug 2015 21:15:04 +0000 Subject: Fix bug with libfat string handling. diff --git a/src/utils/libfat/directory.cpp b/src/utils/libfat/directory.cpp index 765d7ae5..b6d7f01f 100644 --- a/src/utils/libfat/directory.cpp +++ b/src/utils/libfat/directory.cpp @@ -139,7 +139,7 @@ static size_t _FAT_directory_mbstoucs2 (ucs2_t* dst, const char* src, size_t len int bytes; size_t count = 0; - while (count < len-1 && src != '\0') { + while (count < len-1 && *src != '\0') { bytes = mbrtowc (&tempChar, src, MB_CUR_MAX, &ps); if (bytes > 0) { *dst = (ucs2_t)tempChar; 'h' onchange='this.form.submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
AgeCommit message (Expand)Author
2022-11-20gnu: inkbox: Fix build....Marius Bakke
2022-11-20gnu: inkbox: Update home-page and source URI....Marius Bakke
2022-09-16gnu: Add shirah....M
2022-09-16gnu: Add python-ebooklib....M
2022-08-21gnu: cozy: Update to 1.2.1....Vinicius Monego
2022-07-31gnu: qtwebengine: Rename to qtwebengine-5....Maxim Cournoyer
2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....Maxim Cournoyer
2022-02-19gnu: calibre: Improve package style....Nicolas Goaziou
2022-02-19gnu: calibre: Remove input labels....Brendan Tildesley
2022-02-19gnu: calibre: Update to 5.36.0....Brendan Tildesley
2022-02-13gnu: cozy: Update to 1.2.0....Vinicius Monego