From 5676766be5e845ccb6cdf46cfa8722497f151752 Mon Sep 17 00:00:00 2001 From: Jeremy Bicha Date: Fri, 16 Jun 2017 15:11:37 -0400 Subject: Use 'ref' keyword for iter, requires vala 0.36 diff --git a/deja-dup/widgets/ConfigList.vala b/deja-dup/widgets/ConfigList.vala index 15de2d6..02cd81a 100644 --- a/deja-dup/widgets/ConfigList.vala +++ b/deja-dup/widgets/ConfigList.vala @@ -333,7 +333,7 @@ public class ConfigList : ConfigWidget model.row_deleted.disconnect(write_to_config); foreach (Gtk.TreeIter iter in iters) { - (model as Gtk.ListStore).remove(iter); + (model as Gtk.ListStore).remove(ref iter); } model.row_deleted.connect(write_to_config); diff --git a/deja-dup/widgets/ConfigLocation.vala b/deja-dup/widgets/ConfigLocation.vala index 869e2a8..d21c556 100644 --- a/deja-dup/widgets/ConfigLocation.vala +++ b/deja-dup/widgets/ConfigLocation.vala @@ -397,12 +397,12 @@ public class ConfigLocation : ConfigWidget if (uuid == saved_uuid) return; - store.remove(iter); + store.remove(ref iter); if (--num_volumes == 0) { Gtk.TreeIter sep_iter; if (store.get_iter_from_string(out sep_iter, index_vol_sep.to_string())) { - store.remove(sep_iter); + store.remove(ref sep_iter); index_vol_sep = -2; } } -- cgit v0.10.2 38b9a44d1045133e993f372394f9d3c626a72'>commitdiff
path: root/gnu/installer/steps.scm
AgeCommit message (Expand)Author
2020-11-07installer: Limit listbox height....Mathieu Othacehe
2020-09-21installer: Fix docstring typoes....Tobias Geerinckx-Rice
2020-03-05installer: Implement a dialog on /var/guix/installer-socket....Ludovic Courtès
2020-02-22installer: Log important bits to syslog....Ludovic Courtès
2019-05-06installer: Actually translate step descriptions....Ludovic Courtès
2019-04-21installer: Fix skip-to-step issue....Mathieu Othacehe
2019-04-08installer: Generate 'set-xorg-configuration' snippet....Ludovic Courtès
2019-04-07installer: Add dialog to select networking services....Ludovic Courtès
2019-01-17installer: Add configuration formatter....Mathieu Othacehe
2019-01-17gnu: Add graphical installer support....Mathieu Othacehe