From 5676766be5e845ccb6cdf46cfa8722497f151752 Mon Sep 17 00:00:00 2001 From: Jeremy Bicha Date: Fri, 16 Jun 2017 15:11:37 -0400 Subject: Use 'ref' keyword for iter, requires vala 0.36 diff --git a/deja-dup/widgets/ConfigList.vala b/deja-dup/widgets/ConfigList.vala index 15de2d6..02cd81a 100644 --- a/deja-dup/widgets/ConfigList.vala +++ b/deja-dup/widgets/ConfigList.vala @@ -333,7 +333,7 @@ public class ConfigList : ConfigWidget model.row_deleted.disconnect(write_to_config); foreach (Gtk.TreeIter iter in iters) { - (model as Gtk.ListStore).remove(iter); + (model as Gtk.ListStore).remove(ref iter); } model.row_deleted.connect(write_to_config); diff --git a/deja-dup/widgets/ConfigLocation.vala b/deja-dup/widgets/ConfigLocation.vala index 869e2a8..d21c556 100644 --- a/deja-dup/widgets/ConfigLocation.vala +++ b/deja-dup/widgets/ConfigLocation.vala @@ -397,12 +397,12 @@ public class ConfigLocation : ConfigWidget if (uuid == saved_uuid) return; - store.remove(iter); + store.remove(ref iter); if (--num_volumes == 0) { Gtk.TreeIter sep_iter; if (store.get_iter_from_string(out sep_iter, index_vol_sep.to_string())) { - store.remove(sep_iter); + store.remove(ref sep_iter); index_vol_sep = -2; } } -- cgit v0.10.2 uix/diff/gnu/machine?id=e3cf342773e75d9390c92814297de9e2fa21755b'>diff
path: root/gnu/machine
AgeCommit message (Expand)Author
2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas
2020-11-09machine: ssh: Do not import the host (guix config)....Ludovic Courtès
2020-11-01system: Add store-directory-prefix to boot-parameters....Miguel Ángel Arruga Vivas
2020-10-18system: Provide locale information to the bootloader....Miguel Ángel Arruga Vivas
2020-09-07linux-boot: Handle nfs-root device strings....Stefan
2020-08-25Remove "guile-zlib" extension when unused....Mathieu Othacehe
2020-08-25linux-libre: Support module compression....Mathieu Othacehe
2020-07-27machine: ssh: Check for potential system downgrades....Ludovic Courtès
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-06-28Add more missing (ice-9 format) imports....Marius Bakke
2020-06-18machine: ssh: Fix guix deploy hang when using non-DCE UUIDs....Maxim Cournoyer
2020-03-23machine: ssh: Better report missing initrd modules....Ludovic Courtès
2020-03-23machine: ssh: Make sanity checks in a single round trip....Ludovic Courtès
2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice