From 40538ad31a71495649d174b0f7be5f7135d0a905 Mon Sep 17 00:00:00 2001 From: David Wells Date: Sat, 2 Feb 2019 10:00:38 -0500 Subject: [PATCH] Avoid calling a deprecated MPI function. This was deprecated a long time ago (1996) and is not present in the latest version of openMPI (4.0): see https://www.open-mpi.org/faq/?category=mpi-removed Credit goes to Pratik Nayak for finding this issue. --- source/base/mpi.cc | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/source/base/mpi.cc b/source/base/mpi.cc index bd1f7f9846a..b8cd45e7c26 100644 --- a/source/base/mpi.cc +++ b/source/base/mpi.cc @@ -448,7 +448,7 @@ namespace Utilities MPI_Aint displacements[] = {0, offsetof(MinMaxAvg, min_index)}; MPI_Datatype types[] = {MPI_DOUBLE, MPI_INT}; - ierr = MPI_Type_struct(2, lengths, displacements, types, &type); + ierr = MPI_Type_create_struct(2, lengths, displacements, types, &type); AssertThrowMPI(ierr); ierr = MPI_Type_commit(&type); tsummaryrefslogtreecommitdiff
path: root/gnu/packages.scm
AgeCommit message (Expand)Author
2022-01-11shell: Cache profiles even when using package specs....Ludovic Courtès
2020-07-30packages: 'generate-package-cache' is deterministic....Ludovic Courtès
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-01-17packages: Prevent inlining of 'find-best-packages-by-name'....Ludovic Courtès
2020-01-06Adjust module autoloads....Ludovic Courtès
2019-10-14packages: 'fold-available-packages' uses 'supported-package?'....Ludovic Courtès
2019-09-06packages: 'generate-package-cache' uses 'supported-package?'....Ludovic Courtès
2019-06-27Merge branch 'master' into core-updatesLudovic Courtès
2019-06-27packages: 'specification->package+output' distinguishes "no output specified"....Ludovic Courtès
2019-06-14packages: Remove 'search-bootstrap-binary'....Ludovic Courtès
2019-05-01Merge branch 'master' into core-updatesMarius Bakke
2019-03-28packages: Reintroduce 'find-newest-available-packages'....Ludovic Courtès
2019-03-14Merge branch 'staging' into core-updatesMarius Bakke
2019-03-11packages: Add the channel .go files to the search path....Ludovic Courtès
2019-02-20Merge branch 'staging' into core-updatesMarius Bakke
2019-02-16packages: Remove duplicates from package cache....Ludovic Courtès
2019-02-06Merge branch 'master' into core-updatesRicardo Wurmus