sentry-sdk provides a link to sentry.io, a service which monitors applications deployed in the wild.
Defaults to true. Best to just remove the option.
---
dbxfs/main.py | 16 ----------------
setup.py | 1 -
2 files changed, 17 deletions(-)
diff --git a/dbxfs/main.py b/dbxfs/main.py
index 5a6cea1..5d00818 100755
--- a/dbxfs/main.py
+++ b/dbxfs/main.py
@@ -40,8 +40,6 @@ import userspacefs
import keyring
from keyring.errors import KeyringError
-import sentry_sdk
-
from block_tracing import block_tracing, BLOCK_TRACING_INHERITS
from dbxfs.dbxfs import FileSystem as DropboxFileSystem
@@ -299,12 +297,6 @@ def _main(argv=None):
config['keyring_user'] = keyring_user
save_config = True
- if not config.get("asked_send_error_reports", False):
- if yes_no_input("Would you like to help us improve %s by providing anonymous error reports?" % (APP_NAME,), default_yes=True):
- config['send_error_reports'] = True
- config['asked_send_error_reports'] = True
- save_config = True
-
if save_access_token and yes_no_input("Do you want \"%s\" to be the default mount point?" % (mount_point,), default_yes=True):
config['mount_point'] = mount_point
save_config = True
@@ -315,14 +307,6 @@ def _main(argv=None):
log.info("Starting %s...", APP_NAME)
- if config.get('send_error_reports', False):
- try:
- sentry_sdk.init("https://b4b13ebd300849bd92260507a594e618@sentry.io/1293235",
- release='%s@%s' % (APP_NAME, version),
- with_locals=False)
- except Exception:
- log.warning("Failed to initialize sentry", exc_info=True)
-
if cache_folder is None:
cache_folder = os.path.join(appdirs.user_cache_dir(APP_NAME), "file_cache")
try:
diff --git a/setup.py b/setup.py
index 89e25c6..f940d47 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,6 @@ setup(
"privy>=6.0,<7",
"keyring>=15.1.0",
"keyrings.alt>=3.1,<5",
- "sentry_sdk>=0.3,<1",
],
extras_require={
'safefs': ["safefs"],
--
2.28.0
ee2ec8a0941350ee6a297f4b9194'>gnu/packages/libftdi.scm
Age | Commit message (Expand) | Author |
2023-09-14 | gnu: libftdi: Build API documentation....* gnu/packages/libftdi.scm (libftdi)[outputs]: Add "doc" output.
[arguments]<#:configure-flags>: Add "-DDOCUMENTATION".
<#:phases>: Add "install-documentation" phase.
[native-inputs]: Add doxygen, graphviz.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Update to 1.5....* gnu/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/libftdi.scm (libftdi): Update to 1.5.
[source]: Apply patch.
[arguments]<#:configure-flags>: Add "-DFTDIPP", "-DPYTHON_BINDINGS".
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Build Python bindings....* gnu/packages/libftdi.scm (libftdi)[outputs]: Add "python".
[arguments]<#:phases>: Add with "install-python-binding" phase.
[native-inputs]: Add python, swig.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Build C++ bindings....Enabling the C++ bindings allows the test suite to be run, although this fails
without access to the host's USB interface.
* gnu/packages/libftdi.scm (libftdi)[arguments]: Add #:test-target, #:tests?.
(inputs): Add boost.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Build ftdi_eeprom....* gnu/packages/libftdi.scm (libftdi)[arguments]<#:configure-flags>: Add
"-DCMAKE_INSTALL_DOCDIR".
[native-inputs]: Add with pkg-config.
[inputs]: Add with libconfuse.
[license]: Add GPL version 2.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Install libraries to /lib instead of /lib64....* gnu/packages/libftdi.scm (libftdi)[arguments]<#:configure-flags>: Add
"-DLIB_SUFFIX".
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Do not build example programs....* gnu/packages/libftdi.scm (libftdi)[arguments]: Add with "-DEXAMPLES"
configure flag.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Use HTTPS for package source....* gnu/packages/libftdi.scm (libftdi)[source]: Use HTTPS.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |
2023-09-14 | gnu: libftdi: Update package style....* gnu/packages/libftdi.scm: Re-order #:use-module statements.
(libftdi): Wrap long lines; reformat gently.
[license]: Use "license:" prefix.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Simon South |