sentry-sdk provides a link to sentry.io, a service which monitors applications deployed in the wild.
Defaults to true. Best to just remove the option.
---
dbxfs/main.py | 16 ----------------
setup.py | 1 -
2 files changed, 17 deletions(-)
diff --git a/dbxfs/main.py b/dbxfs/main.py
index 5a6cea1..5d00818 100755
--- a/dbxfs/main.py
+++ b/dbxfs/main.py
@@ -40,8 +40,6 @@ import userspacefs
import keyring
from keyring.errors import KeyringError
-import sentry_sdk
-
from block_tracing import block_tracing, BLOCK_TRACING_INHERITS
from dbxfs.dbxfs import FileSystem as DropboxFileSystem
@@ -299,12 +297,6 @@ def _main(argv=None):
config['keyring_user'] = keyring_user
save_config = True
- if not config.get("asked_send_error_reports", False):
- if yes_no_input("Would you like to help us improve %s by providing anonymous error reports?" % (APP_NAME,), default_yes=True):
- config['send_error_reports'] = True
- config['asked_send_error_reports'] = True
- save_config = True
-
if save_access_token and yes_no_input("Do you want \"%s\" to be the default mount point?" % (mount_point,), default_yes=True):
config['mount_point'] = mount_point
save_config = True
@@ -315,14 +307,6 @@ def _main(argv=None):
log.info("Starting %s...", APP_NAME)
- if config.get('send_error_reports', False):
- try:
- sentry_sdk.init("https://b4b13ebd300849bd92260507a594e618@sentry.io/1293235",
- release='%s@%s' % (APP_NAME, version),
- with_locals=False)
- except Exception:
- log.warning("Failed to initialize sentry", exc_info=True)
-
if cache_folder is None:
cache_folder = os.path.join(appdirs.user_cache_dir(APP_NAME), "file_cache")
try:
diff --git a/setup.py b/setup.py
index 89e25c6..f940d47 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,6 @@ setup(
"privy>=6.0,<7",
"keyring>=15.1.0",
"keyrings.alt>=3.1,<5",
- "sentry_sdk>=0.3,<1",
],
extras_require={
'safefs': ["safefs"],
--
2.28.0
guix/log/gnu?id=54e88d8da5ee1c0591b106b63e1c9437967ab52c'>gnu/packages/wireservice.scm
Age | Commit message (Expand) | Author |
2023-05-14 | gnu: csvkit: Update to 1.1.1....* gnu/packages/wireservice.scm (csvkit): Update to 1.1.1.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2023-05-14 | gnu: python-agate: Update to 1.7.1...* gnu/packages/wireservices.scm (python-agate): Update to 1.7.1.
[native-inputs]: Add python-agate-locales.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2023-05-14 | gnu: Add python-agate-locales....* gnu/packages/wireservice.scm (python-agate-locales): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2023-05-14 | gnu: python-agate-sql: Update to 0.5.9....* gnu/packages/wireservices.scm (python-agate-sql): Update to 0.5.9.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2023-05-14 | gnu: python-agate-dbf: Update to 0.2.2....* gnu/packages/wireservices.scm (python-agate-dbf): Update to 0.2.2.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2023-05-09 | gnu: python-leather: Update to 0.3.4....* gnu/packages/wireservice.scm (python-leather): Update to 0.3.4.
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
| Tanguy Le Carrour |
2022-01-19 | gnu: python-agate-excel: Update to 0.2.5....* gnu/packages/wireservice.scm (python-agate-excel): Update to 0.2.5.
[inputs]: Add python-olefile and remove labels.
| Guillaume Le Vaillant |