sentry-sdk provides a link to sentry.io, a service which monitors applications deployed in the wild.
Defaults to true. Best to just remove the option.
---
dbxfs/main.py | 16 ----------------
setup.py | 1 -
2 files changed, 17 deletions(-)
diff --git a/dbxfs/main.py b/dbxfs/main.py
index 5a6cea1..5d00818 100755
--- a/dbxfs/main.py
+++ b/dbxfs/main.py
@@ -40,8 +40,6 @@ import userspacefs
import keyring
from keyring.errors import KeyringError
-import sentry_sdk
-
from block_tracing import block_tracing, BLOCK_TRACING_INHERITS
from dbxfs.dbxfs import FileSystem as DropboxFileSystem
@@ -299,12 +297,6 @@ def _main(argv=None):
config['keyring_user'] = keyring_user
save_config = True
- if not config.get("asked_send_error_reports", False):
- if yes_no_input("Would you like to help us improve %s by providing anonymous error reports?" % (APP_NAME,), default_yes=True):
- config['send_error_reports'] = True
- config['asked_send_error_reports'] = True
- save_config = True
-
if save_access_token and yes_no_input("Do you want \"%s\" to be the default mount point?" % (mount_point,), default_yes=True):
config['mount_point'] = mount_point
save_config = True
@@ -315,14 +307,6 @@ def _main(argv=None):
log.info("Starting %s...", APP_NAME)
- if config.get('send_error_reports', False):
- try:
- sentry_sdk.init("https://b4b13ebd300849bd92260507a594e618@sentry.io/1293235",
- release='%s@%s' % (APP_NAME, version),
- with_locals=False)
- except Exception:
- log.warning("Failed to initialize sentry", exc_info=True)
-
if cache_folder is None:
cache_folder = os.path.join(appdirs.user_cache_dir(APP_NAME), "file_cache")
try:
diff --git a/setup.py b/setup.py
index 89e25c6..f940d47 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,6 @@ setup(
"privy>=6.0,<7",
"keyring>=15.1.0",
"keyrings.alt>=3.1,<5",
- "sentry_sdk>=0.3,<1",
],
extras_require={
'safefs': ["safefs"],
--
2.28.0
399715f2ae18a1'>root/build-aux/update-guix-package.scm
Age | Commit message (Expand) | Author |
2018-12-07 | maint: update-guix-package: Really register GC roots....Previously we'd pass a relative file name to 'add-indirect-root', which
the daemon would interpret as relative to "/". Consequently, checkouts
were not protected from GC.
* build-aux/update-guix-package.scm (main): Pass an absolute file name
to 'add-indirect-root'.
| Ludovic Courtès |
2017-05-09 | maint: update-guix-package: Protect the checkout from GC....* build-aux/update-guix-package.scm (main): Define 'root', and call
'add-indirect-root' to protect SOURCE from GC.
| Ludovic Courtès |
2017-05-07 | maint: Add 'update-guix-package' target....* build-aux/update-guix-package.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
(update-guix-package): New target.
(.PHONY): Add it.
* gnu/packages/package-management.scm (guix): Mention it.
| Ludovic Courtès |
5:38:58 +0200'>2023-07-06installer: Restore LatGrkCyr-8x16 console font depending on language....Partially-Fixes: <https://issues.guix.gnu.org/64006>
* gnu/installer/services.scm (system-services->configuration): When the
LANGUAGE environment variable matches a known native console font, wrap the
base services with modify-services, configuring console-font-service-type to
set the native console font on every tty instead of the default console font.
Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de>
| Denys Nykula |
2022-11-20 | installer: Add comment above the 'packages' field....* gnu/installer/services.scm (system-services->configuration): Add
heading above the 'packages' field. Rename 'heading' to
'service-heading'.
| Ludovic Courtès |