Description: Fix FTBFS if DBUS_HAS_RECURSIVE_MUTEX is undefined Author: Peter Williams Last-Update: 2018-01-26 Taken from Debian: https://sources.debian.org/src/dbus-c++/0.9.0-8.1/debian/patches/07_fix_mutex_ftbfs.patch/ --- dbus-c++-0.9.0.orig/include/dbus-c++/dispatcher.h +++ dbus-c++-0.9.0/include/dbus-c++/dispatcher.h @@ -267,6 +267,19 @@ struct Threading return new Mx; } +#ifndef DBUS_HAS_RECURSIVE_MUTEX + static bool mutex_free(Mutex *mx) + { + delete mx; + return true; + } + + static bool mutex_lock(Mutex *mx) + { + mx->lock(); + return true; + } +#else static void mutex_free(Mutex *mx) { delete mx; @@ -276,6 +289,7 @@ struct Threading { mx->lock(); } +#endif static void mutex_unlock(Mutex *mx) { s Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/NEWS
AgeCommit message (Expand)Author
2021-11-23Update NEWS.Ludovic Courtès
2021-09-23Update NEWS....* NEWS (Distribution): Note new fsck.* arguments and XFS support. Tobias Geerinckx-Rice
2021-09-18Update NEWS.Ludovic Courtès
2021-07-07guix-install.sh: Prompt for configuring substitutes discovery....Also ensure prompt_yes_no always print the message with a trailing space, which is more pleasing to the eye. * etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option. * etc/guix-daemon.service.in: Likewise. * etc/init.d/guix-daemon.in: Likewise. * etc/openrc/guix-daemon.in: Likewise. * etc/guix-install.sh (configure_substitute_discovery): New procedure. (sys_enable_guix_daemon): Ask the user whether automatic substitute discovery should be enabled. Set the '--discover' argument accordingly. (prompt_yes_no): Add a trailing space to the message. (sys_authorize_build_farms): Remove trailing space from the message argument. * NEWS (Distribution): Add news. Maxim Cournoyer
2021-06-29pack: Add support for the deb format....* .dir-locals.el (scheme-mode)[gexp->derivation]: Define indentation rule. * guix/scripts/pack.scm (debian-archive): New procedure. (%formats): Register the new deb format. (show-formats): Add it to the usage string. * tests/pack.scm (%ar-bootstrap): New variable. (deb archive with symlinks): New test. * doc/guix.texi (Invoking guix pack): Document it. * NEWS: Add news entry. Maxim Cournoyer
2021-05-10Update NEWS.Maxim Cournoyer
2021-05-10Update NEWS.Leo Famulari
2021-05-10Update NEWS.Ludovic Courtès
2021-05-04Update NEWS.Ludovic Courtès
2020-11-22Update NEWS.Ludovic Courtès
2020-11-13Update NEWS.Ludovic Courtès
2020-11-09Update NEWS.Ludovic Courtès
2020-11-07Update NEWS.Mathieu Othacehe
2020-11-07Update NEWS.Ludovic Courtès
2020-11-05Update NEWS.Ludovic Courtès