Fix a string comparison in C++ 11.
Taken from Debian:
https://sources.debian.org/src/dbus-c++/0.9.0-8.1/debian/patches/06_fix_gcc-7_ftbfs.patch/
--- a/src/pipe.cpp
+++ b/src/pipe.cpp
@@ -83,5 +83,5 @@ ssize_t Pipe::read(void *buffer, unsigne
void Pipe::signal()
{
// TODO: ignoring return of read/write generates warning; maybe relevant for eventloop work...
- ::write(_fd_write, '\0', 1);
+ ::write(_fd_write, "\0", 1);
}
ttps://git.koszko.org/cgit-static/cgit.png' alt='cgit logo'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-07-09 | nls: Update translations....po/guix/tr.po: New file.
po/guix/LINGUAS: Add it.
| Julien Lepiller |
2022-06-04 | nls: Update translations....po/packages/tr.po: New file.
po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-05-01 | nls: Update translations....po/guix/ja.po: New file.
po/guix/LINGUAS: Add it.
| Julien Lepiller |
2022-04-02 | nls: Update translations....* po/packages/fi.po: New file.
* po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-02-04 | nls: Update translations....* po/doc/guix-cookbook.pt_BR.po: New file.
* po/doc/local.mk: Add it.
* doc/local.mk: Add pt_BR cookbook.
| Julien Lepiller |
2022-01-09 | nls: Update translations....* po/doc/guix-cookbook.fi.po: New file.
* po/doc/guix-manual.fi.po: New file.
* po/doc/local.mk: Add them.
* doc/local.mk: Add them.
* po/guix/fi.po: New file.
* po/guix/LINGUAS: Add it.
| Julien Lepiller |