Fix a string comparison in C++ 11. Taken from Debian: https://sources.debian.org/src/dbus-c++/0.9.0-8.1/debian/patches/06_fix_gcc-7_ftbfs.patch/ --- a/src/pipe.cpp +++ b/src/pipe.cpp @@ -83,5 +83,5 @@ ssize_t Pipe::read(void *buffer, unsigne void Pipe::signal() { // TODO: ignoring return of read/write generates warning; maybe relevant for eventloop work... - ::write(_fd_write, '\0', 1); + ::write(_fd_write, "\0", 1); } /git.koszko.org/cgit-static/cgit.png' alt='cgit logo'/> index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/databases.scm
AgeCommit message (Expand)Author
2020-10-20services: databases: Don't specify a default postgresql version....Christopher Baines
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-03-10tests: databases: Add a system test for PostgreSQL....Christopher Baines
2017-10-08tests: databases: Add a simple test for MySQL....Christopher Baines
2017-10-06services: Add MongoDB....Christopher Baines
2017-08-15gnu: Fix memcached service startup....Christopher Baines
2017-07-30services: Add memcached....Christopher Baines