Copied from upstream: https://github.com/bagder/curl/commit/5c0e66d63214e0306197c5a3f162441e074f3401.patch From 5c0e66d63214e0306197c5a3f162441e074f3401 Mon Sep 17 00:00:00 2001 From: Steve Holme Date: Thu, 8 Jan 2015 19:23:53 +0000 Subject: [PATCH] sasl_gssapi: Fixed build on NetBSD with built-in GSS-API Bug: http://curl.haxx.se/bug/view.cgi?id=1469 Reported-by: Thomas Klausner --- lib/curl_sasl_gssapi.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/lib/curl_sasl_gssapi.c b/lib/curl_sasl_gssapi.c index 6dda0e9..a50646a 100644 --- a/lib/curl_sasl_gssapi.c +++ b/lib/curl_sasl_gssapi.c @@ -6,6 +6,7 @@ * \___|\___/|_| \_\_____| * * Copyright (C) 2014, Steve Holme, . + * Copyright (C) 2015, Daniel Stenberg, , et al. * * This software is licensed as described in the file COPYING, which * you should have received as part of this distribution. The terms @@ -126,7 +127,7 @@ CURLcode Curl_sasl_create_gssapi_user_message(struct SessionHandle *data, /* Import the SPN */ gss_major_status = gss_import_name(&gss_minor_status, &spn_token, - gss_nt_service_name, &krb5->spn); + GSS_C_NT_HOSTBASED_SERVICE, &krb5->spn); if(GSS_ERROR(gss_major_status)) { Curl_gss_log_error(data, gss_minor_status, "gss_import_name() failed: "); -- 2.2.1 href='/guix/diff/gnu/packages/serialization.scm?id=560062aaeabb485e7f53f8f5e6449b9a35aa9ca2'>diff
AgeCommit message (Expand)Author
2024-02-22gnu: python-ruamel-yaml: Update to 0.18.6.Arun Isaac
2024-02-22gnu: python-ruamel.yaml.clib: Update to 0.2.8.Arun Isaac
2024-02-16gnu: Add ckdl.Paul A. Patience
2024-01-10gnu: yaml-cpp: Update to 0.8.0.Zheng Junjie
2024-01-09gnu: msgpack: Deprecate with msgpack-c.Maxim Cournoyer
2023-10-22gnu: Add python-flatbuffers.Ricardo Wurmus
2023-09-17gnu: Remove extraneous imports.Maxim Cournoyer
2023-09-08gnu: tensorflow-lite: Update to 2.12.1.Andy Tai
2023-07-30gnu: capnproto: Update to 1.0 [fixes CVE-2022-46149].Tobias Geerinckx-Rice
2023-07-29gnu: python-msgspec: Regenerate autogenerated file.Vinicius Monego
2023-06-25gnu: Add python-msgspec.Sharlatan Hellseher
2023-05-03gnu: Add libfyaml.Alexey Abramov