This patch allows us to make the libgcrypt dependency optional (which it is, if you look at the code), which in turns allows us to build CRDA without the signature-checking capability on 'regulatory.bin'. --- crda/Makefile 2015-07-17 11:33:33.546712893 +0200 +++ crda/Makefile 2015-07-17 11:34:05.210994373 +0200 @@ -45,12 +45,14 @@ LDLIBS += `pkg-config --libs openssl` $(LIBREG): keys-ssl.c else +ifeq ($(USE_GCRYPT),1) CFLAGS += -DUSE_GCRYPT LDLIBS += -lgcrypt $(LIBREG): keys-gcrypt.c endif +endif MKDIR ?= mkdir -p INSTALL ?= install class='form'>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/artwork.scm
og/tests/guix-package-aliases.sh?id=92b9399fcf5902ef17c37ad1b7e8896578c77b25&showmsg=1'>Expand)
AgeCommit message (Expand)Author
Author
2020-05-11tests: Test 'guix show' with multiple packages....* tests/guix-package-aliases.sh: Test 'guix show' with multiple packages. Ludovic Courtès
2019-09-21guix package: '--show' ignores deprecated packages....* guix/scripts/package.scm (process-query) <'show>: Remove superseded packages. * tests/guix-package-aliases.sh: Add test. Ludovic Courtès
2019-09-21guix package: Add 'guix show' alias....* guix/scripts/show.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add it. * tests/guix-package-aliases.sh: Add test. * doc/guix.texi (Invoking guix package): Document it and use it in a example. Signed-off-by: Ludovic Courtès <ludo@gnu.org> zimoun
2019-04-29guix package: Add 'guix search' alias....* guix/scripts/search.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add it. * tests/guix-package-aliases.sh: Add test. * doc/guix.texi (Invoking guix package): Document it and use it in a couple of examples. Ludovic Courtès
2019-04-29guix package: Add 'install', 'remove', and 'upgrade' aliases....* guix/scripts/install.scm, guix/scripts/remove.scm, guix/scripts/upgrade.scm, tests/guix-package-aliases.sh: New files. * Makefile.am (MODULES, SH_TESTS): Add them. * po/guix/POTFILES.in: Add them. * guix/scripts/package.scm (guix-package): Split with... (guix-package*): ... this. New procedure. * doc/guix.texi (Invoking guix package): Document them. (Binary Installation, Application Setup, Package Management) (Packages with Multiple Outputs, Package Modules) (X.509 Certificates, Installing Debugging Files): Use 'guix install' in simple examples. * etc/completion/bash/guix (_guix_complete): Handle "install", "remove", and "upgrade". Ludovic Courtès