This patch allows us to make the libgcrypt dependency optional (which it
is, if you look at the code), which in turns allows us to build CRDA
without the signature-checking capability on 'regulatory.bin'.
--- crda/Makefile 2015-07-17 11:33:33.546712893 +0200
+++ crda/Makefile 2015-07-17 11:34:05.210994373 +0200
@@ -45,12 +45,14 @@ LDLIBS += `pkg-config --libs openssl`
$(LIBREG): keys-ssl.c
else
+ifeq ($(USE_GCRYPT),1)
CFLAGS += -DUSE_GCRYPT
LDLIBS += -lgcrypt
$(LIBREG): keys-gcrypt.c
endif
+endif
MKDIR ?= mkdir -p
INSTALL ?= install
uix/'>guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-11-28 | gnu: alacritty: Update to 0.14.0....* gnu/packages/terminals.scm (alacritty): Update to 0.14.0.
[arguments]: Remove cargo-test-flags.
[cargo-inputs]: Add rust-tempfile-3, rust-toml-edit-0.22. Replace
rust-base64-0.21 with 0.22, rust-crossfont-0.7 with 0.8,
rust-glutin-0.31 with 0.32, rust-windows-sys-0.48 with 0.52,
rust-winit-0.29 with 0.30. Remove rust-raw-window-handle-0.5.
Change-Id: I376aefac70a5629da91f1e50146ffc7010c27b59
| Efraim Flashner |
2024-11-23 | gnu: bootterm: Improve the package style....* gnu/packages/terminals.scm (bootterm): Improve the package style.
Change-Id: If7c5fc9a51402c9e3fd43c54c5302a937cb5d766
| Artyom V. Poptsov |
2024-11-23 | gnu: bootterm: Use GEXPs....* gnu/packages/terminals.scm (bootterm): Use GEXPs.
Change-Id: I6c718e57eba9304fde8c4ed1fa2f00cf20d44051
| Artyom V. Poptsov |
2024-11-23 | gnu: bootterm: Update to 0.5....* gnu/packages/terminals.scm (bootterm): Update to 0.5.
Change-Id: I374a778bb81e8a37849e1dd592fc247c43be6486
| Artyom V. Poptsov |
2024-10-24 | gnu: foot: Update to 1.19.0....* gnu/packages/terminals.scm (foot): Update to 1.19.0.
Change-Id: Ia25a9f0d2344e11af8ef2b261982876bbc831066
| Ashish SHUKLA |