This patch allows the build process to use the provided dependencies instead
of adding their source as CMake sub-directories (in which case "make install"
would install googletest's and googlebenchmark's libraries and headers).
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57abc26..761c612 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,7 +93,7 @@ SET(CONFU_DEPENDENCIES_BINARY_DIR ${CMAKE_BINARY_DIR}/deps
CACHE PATH "Confu-style dependencies binary directory")
IF(CPUINFO_BUILD_MOCK_TESTS OR CPUINFO_BUILD_UNIT_TESTS)
- IF(CPUINFO_SUPPORTED_PLATFORM AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
+ IF(FALSE)
MESSAGE(STATUS "Downloading Google Test to ${CONFU_DEPENDENCIES_SOURCE_DIR}/googletest (define GOOGLETEST_SOURCE_DIR to avoid it)")
CONFIGURE_FILE(cmake/DownloadGoogleTest.cmake "${CONFU_DEPENDENCIES_BINARY_DIR}/googletest-download/CMakeLists.txt")
EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -105,7 +105,7 @@ IF(CPUINFO_BUILD_MOCK_TESTS OR CPUINFO_BUILD_UNIT_TESTS)
ENDIF()
IF(CPUINFO_BUILD_BENCHMARKS)
- IF(CPUINFO_SUPPORTED_PLATFORM AND NOT DEFINED GOOGLEBENCHMARK_SOURCE_DIR)
+ IF(FALSE)
MESSAGE(STATUS "Downloading Google Benchmark to ${CONFU_DEPENDENCIES_SOURCE_DIR}/googlebenchmark (define GOOGLEBENCHMARK_SOURCE_DIR to avoid it)")
CONFIGURE_FILE(cmake/DownloadGoogleBenchmark.cmake "${CONFU_DEPENDENCIES_BINARY_DIR}/googlebenchmark-download/CMakeLists.txt")
EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -271,14 +271,6 @@ INSTALL(TARGETS cpuinfo
# ---[ cpuinfo micro-benchmarks
IF(CPUINFO_SUPPORTED_PLATFORM AND CPUINFO_BUILD_BENCHMARKS)
- # ---[ Build google benchmark
- IF(NOT TARGET benchmark)
- SET(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "")
- ADD_SUBDIRECTORY(
- "${GOOGLEBENCHMARK_SOURCE_DIR}"
- "${CONFU_DEPENDENCIES_BINARY_DIR}/googlebenchmark")
- ENDIF()
-
IF(CMAKE_SYSTEM_NAME MATCHES "^(Linux|Android)$")
ADD_EXECUTABLE(get-current-bench bench/get-current.cc)
TARGET_LINK_LIBRARIES(get-current-bench cpuinfo benchmark)
@@ -289,7 +281,7 @@ IF(CPUINFO_SUPPORTED_PLATFORM AND CPUINFO_BUILD_BENCHMARKS)
ENDIF()
IF(CPUINFO_SUPPORTED_PLATFORM)
- IF(CPUINFO_BUILD_MOCK_TESTS OR CPUINFO_BUILD_UNIT_TESTS)
+ IF(FALSE)
# ---[ Build google test
IF(NOT TARGET gtest)
IF(MSVC AND NOT CPUINFO_RUNTIME_TYPE STREQUAL "static")
d=9d148d08be9d77781e8103915b1f498b03fd3dd2&showmsg=1'>Expand)
Author |
2023-04-21 | tests: Fix checks for expected failures....Addresses <https://issues.guix.gnu.org/62406>.
With 'set -e', a return status inverted with '!' does not cause the shell to
exit immediately. Instead use '&& false' to indicate an expected failure.
* tests/guix-archive.sh, tests/guix-build-branch.sh, tests/guix-build.sh,
tests/guix-daemon.sh, tests/guix-download.sh,
tests/guix-environment-container.sh, tests/guix-environment.sh,
tests/guix-gc.sh, tests/guix-git-authenticate.sh, tests/guix-graph.sh,
tests/guix-hash.sh, tests/guix-home.sh, tests/guix-pack-relocatable.sh,
tests/guix-pack.sh, tests/guix-package-aliases.sh, tests/guix-package-net.sh,
tests/guix-package.sh, tests/guix-refresh.sh, tests/guix-shell.sh,
tests/guix-style.sh, tests/guix-system.sh: Replace uses of '! ...' with
'... && false' or `test ! ...` as appropriate.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Eric Bavier |
to 3.0.9.
* gnu/packages/package-management.scm (guix-for-cuirass): Remove.
* gnu/packages/ci.scm (cuirass)[inputs]: Replace 'guix-for-cuirass' with
'guix'.
* gnu/packages/patches/guile-continuation-stack-leak.patch,
gnu/packages/patches/guile-cross-compilation.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove them.
Ludovic Courtès |
2023-01-19 | gnu: guile-next: Really depend on self....Previously, when cross-compiling, "self" would point to GUILE-3.0
because it came from (package-native-inputs guile-3.0).
When cross-compiling, ./configure would see a version in 'guile-3.0.pc'
different from its own version and would thus bail out:
building Guile 3.0.8-1.cabbage but `/gnu/store/…/bin/guile' has version 3.0.7
* gnu/packages/guile.scm (guile-next)[native-inputs]: Replace "self".
| Ludovic Courtès |
2023-01-19 | gnu: guile-next: Add '.tarball-version' file to get correct version....So far, "guile --version" and 'guile-3.0.pc' would use "UNKNOWN" as the
version string, making the package unsuitable as a drop-in replacement
for the 'guile-3.0' package.
* gnu/packages/guile.scm (guile-next)[arguments]: Add 'set-version'
phase.
| Ludovic Courtès |
2022-12-11 | gnu: guile-json: Update to 4.7.3....* gnu/packages/guile.scm (guile-json): Update to 4.7.3.
| Vagrant Cascadian |
2022-12-09 | gnu: guile-next: Update to a1a8558....* gnu/packages/guile.scm (guile-next): Update to a1a8558.
| Ludovic Courtès |
2022-11-06 | gnu: guile@3.0.8: Add patch to address continuation memory leak....* gnu/packages/patches/guile-continuation-stack-leak.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/guile.scm (guile-3.0-latest)[source]: Use it.
| Ludovic Courtès |
2022-08-07 | gnu: guile-sqlite3: Update to 0.1.3....* gnu/packages/guile.scm (guile-sqlite3): Update to 0.1.3.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Olivier Dion |
2022-06-24 | gnu: guile-json: Update to 4.7.1....* gnu/packages/guile.scm (guile-json-4): Update to 4.7.1.
| Ludovic Courtès |