Add an extra layer of quoting to ltmain.sh sanity check.
--- a/configure 2005-05-07 14:19:31.000000000 +0200
+++ b/configure 2015-02-10 11:16:32.456146934 +0100
@@ -6266,7 +6266,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
--- a/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
+++ b/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
@@ -246,7 +246,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
AC_MSG_RESULT(no)
echo
--- a/libcpufreq/configure 2005-05-07 14:19:31.000000000 +0200
+++ b/libcpufreq/configure 2015-02-10 11:16:32.456146934 +0100
@@ -6266,7 +6266,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
--- a/libcpufreq/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
+++ b/libcpufreq/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
@@ -246,7 +246,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
AC_MSG_RESULT(no)
echo
da793c607acc161bdf9ec5535'>root/tests/cve.scm
Age | Commit message (Expand) | Author |
2019-10-23 | cve: Rewrite to read the JSON feed instead of the XML feed....The XML feed was discontinued on Oct. 16th, 2019:
<https://nvd.nist.gov/General/News/XML-Vulnerability-Feed-Retirement-Phase-3>
* guix/cve.scm (string->date*): New procedure.
(<cve-item>, <cve>, <cve-reference>): New record types.
(cpe-match->cve-configuration, configuration-data->cve-configurations)
(json->cve-items, version-matches?): New procedures.
(yearly-feed-uri): Change URL to refer to JSON feed.
(cpe->product-alist, %parse-vulnerability-feed)
(xml->vulnerabilities): Remove.
(cve-configuration->package-list, merge-package-lists)
(cve-item->vulnerability, json->vulnerabilities): New procedures.
(write-cache): Use 'json->vulnerabilities' instead of
'xml->vulnerabilities', and remove 'parameterize'.
(vulnerabilities->lookup-proc): Use 'version-matches?' when VERSION is
true.
* tests/cve.scm (%sample): Use 'tests/cve-sample.json'.
(%expected-vulnerabilities): Rewrite accordingly.
("json->cve-items", "cve-item-published-date")
("json->vulnerabilities"): New tests.
("xml->vulnerabilities"): Remove.
("vulnerabilities->lookup-proc"): Adjust to new vulnerabilities.
* tests/cve-sample.json: New file.
* tests/cve-sample.xml: Remove.
* Makefile.am (EXTRA_DIST): Adjust accordingly.
* doc/guix.texi (Invoking guix lint): Update nist.gov URLs.
| Ludovic Courtès |
2019-10-20 | tests: Avoid now-deprecated 'make-struct'....* tests/cve.scm (vulnerability): Use 'make-struct/no-tail' instead of
'make-struct', which is deprecated.
* tests/lint.scm ("cve: one vulnerability")
("cve: one patched vulnerability")
("cve: known safe from vulnerability")
("cve: vulnerability fixed in replacement version")
("cve: patched vulnerability in replacement"): Likewise.
| Ludovic Courtès |