Add an extra layer of quoting to ltmain.sh sanity check.
--- a/configure 2005-05-07 14:19:31.000000000 +0200
+++ b/configure 2015-02-10 11:16:32.456146934 +0100
@@ -6266,7 +6266,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
--- a/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
+++ b/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
@@ -246,7 +246,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
AC_MSG_RESULT(no)
echo
--- a/libcpufreq/configure 2005-05-07 14:19:31.000000000 +0200
+++ b/libcpufreq/configure 2015-02-10 11:16:32.456146934 +0100
@@ -6266,7 +6266,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
--- a/libcpufreq/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
+++ b/libcpufreq/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
@@ -246,7 +246,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
AC_MSG_RESULT(no)
echo
lass='path'>path: root/gnu/packages/aidc.scm
Age | Commit message (Expand) | Author |
2021-06-19 | Merge branch 'master' into core-updates...Note: this merge actually changes the 'curl' and 'python-attrs' derivations,
as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and
12964df69a99de6190422c752fef65ef813f3b6b respectively.
4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it
cannot currently be tested.
Conflicts:
gnu/local.mk
gnu/packages/aidc.scm
gnu/packages/boost.scm
gnu/packages/curl.scm
gnu/packages/nettle.scm
gnu/packages/networking.scm
gnu/packages/python-xyz.scm
gnu/packages/tls.scm
| Marius Bakke |
2021-06-14 | gnu: Rename qtbase to qtbase-5....This change was automated via the following command:
$ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g'
$ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g'
$ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g'
$ git checkout etc # to clear some spurious changes
This is done so the qtbase package can be upgraded to version 6 in the
following commit.
| Maxim Cournoyer |