Remove Check updates button and Auto check updates option.
Upstream status: Guix-specific, not forwarded upstream.
diff --git a/src/dialogoptions.cpp b/src/dialogoptions.cpp
index 704e75c..bb3f9b0 100755
--- a/src/dialogoptions.cpp
+++ b/src/dialogoptions.cpp
@@ -71,23 +71,10 @@ void DialogOptions::setOverwriteMode()
IniSettings::setOverwriteMode(true);
}
-void DialogOptions::setAutoUpdates()
-{
- bool enabled;
-
- if (checkCheckUpdates->isChecked())
- enabled = true;
- else
- enabled = false;
-
- IniSettings::setAutoChechUpdates(enabled);
-}
-
void DialogOptions::saveOptions()
{
setLanguage();
setOverwriteMode();
- setAutoUpdates();
IniSettings::settings->sync();
accept();
@@ -102,12 +89,6 @@ void DialogOptions::loadSettings()
else
radioAskFirst->setChecked(true);
- bool autoUpdates = IniSettings::isAutoChechUpdates();
- if (autoUpdates)
- checkCheckUpdates->setCheckState(Qt::Checked);
- else
- checkCheckUpdates->setCheckState(Qt::Unchecked);
-
Translator t;
int idx = comboLangs->findText(t.currentLanguage(), Qt::MatchExactly);
diff --git a/src/mainwindowimpl.cpp b/src/mainwindowimpl.cpp
index 6562e35..d19bc28 100755
--- a/src/mainwindowimpl.cpp
+++ b/src/mainwindowimpl.cpp
@@ -163,7 +163,6 @@ void MainWindowImpl::createActions()
connect(actionInfo, SIGNAL(triggered()), this, SLOT(about()));
connect(actionDonatePaypal, SIGNAL(triggered()), this, SLOT(openPaypalLink()));
connect(actionReportBug, SIGNAL(triggered()), this, SLOT(bugReport()));
- connect(actionCheckForUpdates, SIGNAL(triggered()), this, SLOT(checkForUpdates()));
connect(actionHelp, SIGNAL(triggered()), this, SLOT(onlineHelp()));
// Create first toolbar button
diff --git a/ui/dialogoptions.ui b/ui/dialogoptions.ui
index e59148d..6cb23f5 100755
--- a/ui/dialogoptions.ui
+++ b/ui/dialogoptions.ui
@@ -66,22 +66,6 @@
- -
-
-
- Updates
-
-
-
-
-
-
- Checks for updates automatically
-
-
-
-
-
-
-
-
diff --git a/ui/mainwindow.ui b/ui/mainwindow.ui
index 569565f..b86fc2e 100755
--- a/ui/mainwindow.ui
+++ b/ui/mainwindow.ui
@@ -356,7 +356,6 @@
-
@@ -1412,14 +1411,6 @@ p, li { white-space: pre-wrap; }
Import windows icon (*.ico *.icon)
-
-
- &Check for updates
-
-
- Check if a new version of Converseen is available
-
-