Remove pointers to PayPal and Facebook.
Upstream status: Guix-specific, not forwarded upstream.
diff --git a/src/dialoginfo.cpp b/src/dialoginfo.cpp
index 52dd628..b37c413 100755
--- a/src/dialoginfo.cpp
+++ b/src/dialoginfo.cpp
@@ -33,7 +33,6 @@ DialogInfo::DialogInfo(QWidget *parent) :
setupUi(this);
connect(pushClose, SIGNAL(clicked()), this, SLOT(close()));
- connect(pushFacebook, SIGNAL(clicked()), this, SLOT(openFacebookPage()));
QString appVersion;
QString magickVersion;
@@ -66,62 +65,4 @@ DialogInfo::DialogInfo(QWidget *parent) :
.arg(qtVersionStrTr)
.arg(QT_VERSION_STR);
labelQtVersion->setText(qt_versionString);
-
- // This section generates a Text + Png pixmap icon for the donazion button!
-
- QString donateText = tr("Make a Donation!");
- QString donateDescriptionText = tr("Donate using PayPal, Ko-Fi or Cryptocurrencies.");
-
- QString htmlDonationText = QString(R"(
-
-
-
-
- |
-
- %1
- %2
- |
-
-
- )")
- .arg(donateText, donateDescriptionText);
-
- QTextDocument donateHtmlText;
- donateHtmlText.setHtml(htmlDonationText);
-
- QPixmap pixmapDonationText(donateHtmlText.size().width(), donateHtmlText.size().height());
- pixmapDonationText.fill( Qt::transparent );
-
- QPainter painter( &pixmapDonationText );
- painter.setRenderHint(QPainter::Antialiasing, true);
-
- donateHtmlText.drawContents(&painter, pixmapDonationText.rect());
-
- QIcon donateButtonIcon(pixmapDonationText);
- pushDonatePayPal->setIcon(donateButtonIcon);
- pushDonatePayPal->setIconSize(pixmapDonationText.rect().size());
-
- adjustSize();
- this->resize(512, 800);
-}
-
-void DialogInfo::openFacebookPage()
-{
- QDesktopServices::openUrl(QUrl("https://www.facebook.com/converseen", QUrl::TolerantMode));
}
-
-void DialogInfo::on_pushDonatePayPal_clicked()
-{
- QDesktopServices::openUrl(QUrl("https://converseen.fasterland.net/donate/", QUrl::TolerantMode));
-}
-
diff --git a/src/dialoginfo.h b/src/dialoginfo.h
index 4d8ba15..ef6afa9 100755
--- a/src/dialoginfo.h
+++ b/src/dialoginfo.h
@@ -32,8 +32,6 @@ public:
DialogInfo(QWidget *parent = 0);
private slots:
- void openFacebookPage();
- void on_pushDonatePayPal_clicked();
};
#endif // DIALOGINFO_H
diff --git a/src/mainwindowimpl.cpp b/src/mainwindowimpl.cpp
index 71ddc2c..bd4294b 100755
--- a/src/mainwindowimpl.cpp
+++ b/src/mainwindowimpl.cpp
@@ -163,7 +163,6 @@ void MainWindowImpl::createActions()
connect(actionConvert, SIGNAL(triggered()), this, SLOT(elabora()));
connect(actionInfo, SIGNAL(triggered()), this, SLOT(about()));
- connect(actionDonatePaypal, SIGNAL(triggered()), this, SLOT(openPaypalLink()));
connect(actionReportBug, SIGNAL(triggered()), this, SLOT(bugReport()));
connect(actionCheckForUpdates, SIGNAL(triggered()), this, SLOT(checkForUpdates()));
connect(actionHelp, SIGNAL(triggered()), this, SLOT(onlineHelp()));
diff --git a/ui/dialoginfo.ui b/ui/dialoginfo.ui
index 2878670..0535a85 100755
--- a/ui/dialoginfo.ui
+++ b/ui/dialoginfo.ui
@@ -273,146 +273,6 @@ p, li { white-space: pre-wrap; }
- -
-
-
-
-
-
- <html><head/><body><p align="center"><span style=" font-weight:600;">If you appreciate this work and would like to support the project, you are welcome to donate via PayPal</span></p></body></html>
-
-
- true
-
-
-
- -
-
-
-
-
-
- Qt::Horizontal
-
-
-
- 40
- 20
-
-
-
-
- -
-
-
- PointingHandCursor
-
-
-
-
-
-
- 150
- 50
-
-
-
- false
-
-
- true
-
-
-
- -
-
-
- Qt::Horizontal
-
-
-
- 40
- 20
-
-
-
-
-
-
-
-
- -
-
-
- Qt::Horizontal
-
-
-
- -
-
-
-
-
-
- Qt::Horizontal
-
-
-
- 40
- 20
-
-
-
-
- -
-
-
-
-
-
- <html><head/><body><p><span style=" font-size:11pt; font-weight:600;">Follow Converseen:</span></p></body></html>
-
-
-
- -
-
-
- PointingHandCursor
-
-
-
-
-
-
- :/Images/res/facebook-icon.png:/Images/res/facebook-icon.png
-
-
-
- 32
- 32
-
-
-
- false
-
-
- true
-
-
-
-
-
- -
-
-
- Qt::Horizontal
-
-
-
- 40
- 20
-
-
-
-
-
-
-
diff --git a/ui/mainwindow.ui b/ui/mainwindow.ui
index 24bda6f..e8a072d 100755
--- a/ui/mainwindow.ui
+++ b/ui/mainwindow.ui
@@ -1408,18 +1408,6 @@ p, li { white-space: pre-wrap; }
&About
-
-
-
- :/Images/res/heart.png:/Images/res/heart.png
-
-
- &Donate!
-
-
- Donate via Paypal, Ko-Fi, Cryptocurrencies
-
-
&Report bug...