Copyright © 2022 Oleg Pykhalov Create a PID file after containerd is ready to serve requests. Fixes . --- a/cmd/containerd/command/notify_linux.go 1970-01-01 03:00:01.000000000 +0300 +++ b/cmd/containerd/command/notify_linux.go 2022-07-02 04:42:35.553753495 +0300 @@ -22,15 +22,22 @@ sd "github.com/coreos/go-systemd/v22/daemon" "github.com/containerd/containerd/log" + + "os" + "strconv" ) // notifyReady notifies systemd that the daemon is ready to serve requests func notifyReady(ctx context.Context) error { + pidFile, _ := os.Create("/run/containerd/containerd.pid") + defer pidFile.Close() + pidFile.WriteString(strconv.FormatInt(int64(os.Getpid()), 10)) return sdNotify(ctx, sd.SdNotifyReady) } // notifyStopping notifies systemd that the daemon is about to be stopped func notifyStopping(ctx context.Context) error { + os.Remove("/run/containerd/containerd.pid") return sdNotify(ctx, sd.SdNotifyStopping) } ='/guix/about/'>aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2024-07-18guix: channels: Enable specifiying available builtin builders....Christopher Baines
2024-04-19maint: Generate doc/version[-LANG].texi using `mdate-from-git.scm'....Janneke Nieuwenhuizen
2024-04-19maint: Support `make doc-pot-update' from a tarball....Janneke Nieuwenhuizen
2024-04-14maint: Fix header....Janneke Nieuwenhuizen
2024-04-14maint: Use xgettext.scm wrapper to create .PO files reproducibly....Janneke Nieuwenhuizen
2024-01-05build: test-driver.scm: Set mode....Tomas Volf
2023-08-21maint: Add 'etc/hurd-manifest.scm'....Janneke Nieuwenhuizen
2023-07-25cuirass: Update hurd-manifest with newly supported packages....Janneke Nieuwenhuizen
2022-05-26cuirass: Create just as many threads as needed....Ludovic Courtès
2022-05-26cuirass: Fork inferior processes before creating threads....Ludovic Courtès
2022-05-20cuirass: Close each inferior upon completion....Ludovic Courtès