IO not appropriate in the context of a sorting routine, and in any case the
proper headers are not included, so gcc emits an undefined symbol error.
Remove the "printf" statement.
--- CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
+++ CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
@@ -142,7 +142,6 @@
}
if ( (a[nmax]==a[nmin]) && (ctr==0) )
{
- printf("All the numbers are identical, the list is sorted\n");
return;
}
>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-11-12 | gnu: chicken: Update to 5.4.0....* gnu/packages/chicken.scm (chicken): Update to 5.4.0.
Change-Id: I448bdc25a5cb11e55c7ebb9d9e0cf1876ca958d8
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Ashish SHUKLA |
2024-08-31 | gnu: Do not eagerly load (gnu packages commencement)....As its top comment says, this module is not meant to be imported to avoid
circular module dependencies.
* gnu/packages/chicken.scm (chicken) [propagated-inputs]: Resolve
gcc-toolchain lazily.
* gnu/packages/plan9.scm (plan9port): Likewise.
* gnu/packages/raspberry-pi.scm (raspi-arm64-chainloader)
[native-inputs]: Resolve ld-wrapper lazily.
Change-Id: Ie9859046ed32b67dc53bcc5444d6ae162e5d4022
| Maxim Cournoyer |
2024-07-22 | Revert "gnu: chicken: Update to 5.4.0."...This reverts commit 9c3c2293fdc22a6b032bf41d09a6ebe4442324cb.
| jgart |
2024-07-19 | gnu: chicken: Update to 5.4.0....* gnu/packages/chicken.scm (chicken): Update to 5.4.0.
Change-Id: I448bdc25a5cb11e55c7ebb9d9e0cf1876ca958d8
Signed-off-by: jgart <jgart@dismail.de>
| Ashish SHUKLA |
2023-12-12 | gnu: chicken: Update to 5.3.0....* gnu/packages/chicken.scm (chicken): Update to 5.3.0.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: Id3ec15da586ddfc6dae924c0c8031fd7a4613660
| Daniel Ziltener |
2023-04-30 | gnu: Add chicken-srfi-18....* gnu/packages/chicken.scm (chicken-srfi-18): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Kristian Lein-Mathisen |
2023-04-30 | gnu: Add chicken-compile-file....* gnu/packages/chicken.scm (chicken-compile-file): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Kristian Lein-Mathisen |