Install BipartiteMatchings headers for SuperLU_DIST. --- a/BipartiteMatchings/ApproxWeightPerfectMatching.h +++ b/BipartiteMatchings/ApproxWeightPerfectMatching.h @@ -9,7 +9,7 @@ #ifndef ApproxWeightPerfectMatching_h #define ApproxWeightPerfectMatching_h -#include "../CombBLAS.h" +#include "CombBLAS.h" #include "BPMaximalMatching.h" #include "BPMaximumMatching.h" #include --- a/BipartiteMatchings/BPMaximalMatching.h +++ b/BipartiteMatchings/BPMaximalMatching.h @@ -1,7 +1,7 @@ #ifndef BP_MAXIMAL_MATCHING_H #define BP_MAXIMAL_MATCHING_H -#include "../CombBLAS.h" +#include "CombBLAS.h" #include #include #include --- a/BipartiteMatchings/BPMaximumMatching.h +++ b/BipartiteMatchings/BPMaximumMatching.h @@ -1,7 +1,7 @@ #ifndef BP_MAXIMUM_MATCHING_H #define BP_MAXIMUM_MATCHING_H -#include "../CombBLAS.h" +#include "CombBLAS.h" #include #include #include --- a/BipartiteMatchings/MatchingDefs.h +++ b/BipartiteMatchings/MatchingDefs.h @@ -9,7 +9,7 @@ #ifndef MatchingDefs_h #define MatchingDefs_h -#include "../CombBLAS.h" +#include "CombBLAS.h" #include namespace combblas { --- a/BipartiteMatchings/Utility.h +++ b/BipartiteMatchings/Utility.h @@ -1,7 +1,7 @@ #ifndef BP_UTILITY_H #define BP_UTILITY_H -#include "../CombBLAS.h" +#include "CombBLAS.h" namespace combblas { --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -68,6 +68,7 @@ set_property(TARGET CombBLAS PROPERTY VERSION ${CombBLAS_VERSION}) # installation install(DIRECTORY include/ DESTINATION include) install(DIRECTORY psort-1.0/include/ DESTINATION include) +install(DIRECTORY BipartiteMatchings DESTINATION include FILES_MATCHING PATTERN "*.h") install(TARGETS CombBLAS EXPORT CombBLASTargets LIBRARY DESTINATION lib ARCHIVE DESTINATION lib ue='range'>range
AgeCommit message (Expand)Author
2019-05-15marionette: Add braces to the keystrokes....Ludovic Courtès
2018-08-28marionette: Add wait-for-unix-socket....Chris Marusich
2018-08-28marionette: Add support for QEMU's "quit" command....Chris Marusich
2018-06-01marionette: Add 'wait-for-tcp-port'....Ludovic Courtès
2018-02-19marionette: Use QEMU's "VM channel" mechanism....Ludovic Courtès
2017-09-08marionette: 'wait-for-file' can be passed a read procedure....Ludovic Courtès
2017-08-28marionette: Augment the set of keystrokes....Ludovic Courtès
2017-08-28marionette: Fix typing of capital letters....Ludovic Courtès
2017-08-28marionette: 'wait-for-file' really raises an error when a file is missing....Ludovic Courtès
2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès