Disable creation of /var and /etc
--- a/Makefile.am 2020-03-08 16:57:09.511535600 +0100
+++ b/Makefile.am 2020-04-21 11:36:49.827182272 +0200
@@ -2376,16 +2376,6 @@
endif
install-exec-hook:
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/lib/$(PACKAGE_NAME)
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/log
- $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
- if test -e $(DESTDIR)$(sysconfdir)/collectd.conf; \
- then \
- $(INSTALL) -m 0640 $(builddir)/src/collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf.pkg-orig; \
- else \
- $(INSTALL) -m 0640 $(builddir)/src/collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf; \
- fi; \
$(mkinstalldirs) $(DESTDIR)$(cpkgdatadir)
$(INSTALL) -m 0644 $(srcdir)/src/types.db $(DESTDIR)$(cpkgdatadir)/types.db;
$(INSTALL) -m 0644 $(srcdir)/src/postgresql_default.conf \
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-05-26 | cuirass: Create just as many threads as needed....* build-aux/cuirass/evaluate.scm (command-line): Change second argument
to 'n-par-for-each'.
| Ludovic Courtès |
2022-05-26 | cuirass: Fork inferior processes before creating threads....Works around <https://issues.guix.gnu.org/55441#12>.
Start from commit bd86bbd300474204878e927f6cd3f0defa1662a5,
'open-inferior' uses 'primitive-fork' instead of 'open-pipe*'. As a
result, child process could potentially hang before calling 'execl' due
to undefined behavior when forking a multi-threaded process.
* build-aux/cuirass/evaluate.scm <top level>: Call 'open-inferior'
before 'n-par-for-each'.
| Ludovic Courtès |
2022-05-20 | cuirass: Close each inferior upon completion....* build-aux/cuirass/evaluate.scm <top level>: Add 'close-inferior' call.
| Ludovic Courtès |
2021-12-22 | tests: Move keys into ./tests/keys/ and add a third ed25519 key....The third key will be used in an upcoming commit.
Rename public keys to .pub.
* guix/tests/gnupg.scm (%ed25519-3-public-key-file): New variable.
(%ed25519-3-secret-key-file): New variable.
(%ed25519-2-public-key-file): Renamed from %ed25519bis-public-key-file.
(%ed25519-2-secret-key-file): Renamed from %ed25519bis-secret-key-file.
* tests/keys/ed25519-3.key: New file.
* tests/keys/ed25519-3.sec: New file.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Attila Lendvai |
2021-11-27 | build-self: Help users to submit useful bug reports....* build-aux/build-self.scm (build): Request the ‘COMPLETE output’.
| Tobias Geerinckx-Rice |