Remove dependencies on bundled zlib, pcre and expat.
diff --git a/Makefile.in b/Makefile.in
index 4360a26..80f9f59 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -210,8 +210,7 @@ coda_matlab_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
@BUILD_MATLAB_TRUE@@SUBPACKAGE_MODE_FALSE@ -rpath \
@BUILD_MATLAB_TRUE@@SUBPACKAGE_MODE_FALSE@ $(matlabmexexecdir)
am__DEPENDENCIES_1 =
-libcoda_la_DEPENDENCIES = @LTLIBOBJS@ libexpat_internal.la \
- libpcre_internal.la libz_internal.la $(am__DEPENDENCIES_1) \
+libcoda_la_DEPENDENCIES = @LTLIBOBJS@ $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
am__libcoda_la_SOURCES_DIST = libcoda/coda-ascbin-cursor.c \
libcoda/coda-ascbin.h libcoda/coda-ascii-cursor.c \
@@ -306,8 +305,7 @@ libcoda_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(libcoda_la_LDFLAGS) $(LDFLAGS) -o $@
@SUBPACKAGE_MODE_FALSE@am_libcoda_la_rpath = -rpath $(libdir)
-am__DEPENDENCIES_2 = @LTLIBOBJS@ libexpat_internal.la \
- libpcre_internal.la libz_internal.la $(am__DEPENDENCIES_1) \
+am__DEPENDENCIES_2 = @LTLIBOBJS@ $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
libcoda_internal_la_DEPENDENCIES = $(am__DEPENDENCIES_2)
am__libcoda_internal_la_SOURCES_DIST = libcoda/coda-ascbin-cursor.c \
@@ -898,8 +896,8 @@ INSTALL_DATA_HOOK_TARGETS = $(am__append_1)
UNINSTALL_HOOK_TARGETS =
CLEAN_LOCAL_TARGETS = $(am__append_11)
ALL_LOCAL_TARGETS =
-@SUBPACKAGE_MODE_FALSE@noinst_LTLIBRARIES = libcoda_internal.la libexpat_internal.la libpcre_internal.la libz_internal.la
-@SUBPACKAGE_MODE_TRUE@noinst_LTLIBRARIES = libcoda_internal.la libexpat_internal.la libpcre_internal.la libz_internal.la
+@SUBPACKAGE_MODE_FALSE@noinst_LTLIBRARIES = libcoda_internal.la
+@SUBPACKAGE_MODE_TRUE@noinst_LTLIBRARIES = libcoda_internal.la
# libraries (+ related files)
@SUBPACKAGE_MODE_FALSE@lib_LTLIBRARIES = libcoda.la
@@ -1048,7 +1046,7 @@ libcoda_hdf5_files = \
libcoda_la_CPPFLAGS = -Ilibcoda/expat -I$(srcdir)/libcoda/expat -Ilibcoda/pcre -I$(srcdir)/libcoda/pcre -Ilibcoda/zlib -I$(srcdir)/libcoda/zlib $(AM_CPPFLAGS)
libcoda_la_LDFLAGS = -no-undefined -version-info $(LIBCODA_CURRENT):$(LIBCODA_REVISION):$(LIBCODA_AGE)
-libcoda_la_LIBADD = @LTLIBOBJS@ libexpat_internal.la libpcre_internal.la libz_internal.la $(HDF4LIBS) $(HDF5LIBS)
+libcoda_la_LIBADD = @LTLIBOBJS@ $(HDF4LIBS) $(HDF5LIBS)
libcoda_internal_la_SOURCES = libcoda/coda-ascbin-cursor.c \
libcoda/coda-ascbin.h libcoda/coda-ascii-cursor.c \
libcoda/coda-ascii-internal.h libcoda/coda-ascii.c \
06-09
tests: Ensure 'elpa' test does not access the network....Previously it would try to access the real elpa.gnu.org. This would
succeed when network is available because "taxy-magit-section" is an
existing package.
* guix/import/elpa.scm (elpa-repository)
(package-from-elpa-repository?): Recognize 'gnu/http.
* tests/elpa.scm ("package-latest-release"): Use 'http' instead of
'https'. Change "taxy-magit-section" to "fake-taxy-magit-section".
| Ludovic Courtès |
2023-05-31 | tests: Use quasiquoted 'match' patterns for package sexps....Turns out it's easier to read.
* tests/cpan.scm ("cpan->guix-package"): Use a quasiquoted pattern.
* tests/elpa.scm (eval-test-with-elpa): Likewise.
* tests/gem.scm ("gem->guix-package")
("gem->guix-package with a specific version")
("gem-recursive-import")
("gem-recursive-import with a specific version"): Likewise.
* tests/hexpm.scm ("hexpm-recursive-import"): Likewise.
* tests/opam.scm ("opam->guix-package"): Likewise.
* tests/pypi.scm ("pypi->guix-package, no wheel")
("pypi->guix-package, wheels")
("pypi->guix-package, no usable requirement file.")
("pypi->guix-package, package name contains \"-\" followed by digits"):
Likewise.
* tests/texlive.scm ("texlive->guix-package"): Likewise.
| Ludovic Courtès |
2023-05-31 | import: elpa: Updater provides input list....* guix/import/elpa.scm (elpa-dependency->upstream-input): New
procedure.
(latest-release): Add 'inputs' field.
* tests/elpa.scm ("package-latest-release"): New test.
| Ludovic Courtès |
2021-12-18 | import: elpa: Support ‘upstream-name’ property....* guix/import/elpa.scm: (guix-package->elpa-name): New procedure.
(latest-release): Use it.
* tests/elpa.scm ("guix-package->elpa-name: without 'upstream-name' property")
("guix-package->elpa-name: with 'upstream-name' property"): Test it.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Xinglu Chen |
2021-03-06 | tests: do not hard code HTTP ports...Previously, test cases could fail if some process was listening
at a hard-coded port. This patch eliminates most of these potential
failures, by automatically assigning an unbound port. This should
allow for building multiple guix trees in parallel outside a build
container, though this is currently untested.
The test "home-page: Connection refused" in tests/lint.scm still
hardcodes port 9999, however.
* guix/tests/http.scm
(http-server-can-listen?): remove now unused procedure.
(%http-server-port): default to port 0, meaning the OS
will automatically choose a port.
(open-http-server-socket): remove the false statement claiming
this procedure is exported and also return the allocated port
number.
(%local-url): raise an error if the port is obviously unbound.
(call-with-http-server): set %http-server-port to the allocated
port while the thunk is called.
* tests/derivations.scm: adjust test cases to use automatically
assign a port. As there is no risk of a port conflict now,
do not make any tests conditional upon 'http-server-can-listen?'
anymore.
* tests/elpa.scm: likewise.
* tests/lint.scm: likewise, and add a TODO comment about a port
that is still hard-coded.
* tests/texlive.scm: likewise.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Maxime Devos |