Suppress a warning from grep which causes tests to fail.
Taken from upstream pull request:
https://github.com/aureliojargas/clitest/pull/54
diff --git a/test/inline-match-egrep.sh b/test/inline-match-egrep.sh
--- a/test/inline-match-egrep.sh
+++ b/test/inline-match-egrep.sh
@@ -42,7 +42,7 @@ $ printf ' \t \t\t \n' #=> --egrep ^ $
# egrep regexes. You'll need to test in your system if that's the
# case. I recommend using a literal tab to avoid problems.
-$ printf 'may\tfail' #=> --egrep ^may\tfail$
+$ printf 'may\tfail' #=> --egrep ^may\\tfail$
$ printf 'may\tfail' #=> --egrep ^may[\t]fail$
$ printf 'will\tmatch' #=> --egrep ^will match$
@@ -51,7 +51,7 @@ $ printf 'will\tmatch' #=> --egrep ^will match$
# These tests will fail:
$ printf 'will\nfail' #=> --egrep will.*fail
-$ printf 'will\nfail' #=> --egrep will\nfail
+$ printf 'will\nfail' #=> --egrep will\\nfail
# If one line of a multiline results matches, the test is OK
boutsummaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-09-08 | gnu: boost-signals2: Use G-expressions....* gnu/packages/boost.scm (boost-signals2)[arguments]:
Rewrite as G-expressions.
Change-Id: I83c05f97089cae8a14fedf52c34e898addfb5701
| Tobias Geerinckx-Rice |
2024-09-08 | gnu: boost-signals2: Update to 1.83.0-0.2ecf1b5....This ‘fixes’ the build as our hash no longer matched upstream's Git tag.
* gnu/packages/boost.scm (boost-signals2): Update to 1.83.0-0.2ecf1b5.
Change-Id: I1e0849ac71bcba22c8b367601107caf58b51a434
| Tobias Geerinckx-Rice |
2024-08-31 | gnu: Boost: Fix a bug that breaks libetonyek....This fixes <https://issues.guix.gnu.org/72040>.
* gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/boost.scm (boost)[source]: Use it.
(boost-for-source-highlight): New variable, not using the patch.
* gnu/packages/pretty-print.scm (source-highlight)[inputs]: Replace BOOST with
BOOST-FOR-SOURCE-HIGHLIGHT.
Change-Id: I5fbc9eb5000aefd7d3a14cc7a0482741032b5400
| Leo Famulari |
2024-08-31 | gnu: boost: Update to 1.83.0....* gnu/packages/boost.scm (boost): Update to 1.83.0.
[source](patches): Add new and remove old upstream patches.
(patch-flags): Strip prefix to match source directory structure.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I68d0d50ea916c938d4b30e8e074202a9380cfa0b
| Greg Hogan |
2024-08-31 | gnu: boost: Import the correct set of modules....* gnu/packages/boost.scm (boost) [arguments] <modules>: Replace
%default-gnu-imported-modules with %default-gnu-modules.
Change-Id: Idb491a2b7cae3a52783a2c92b78b362de0adf49e
| Maxim Cournoyer |
2024-08-31 | build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private
%default-modules variable of (guix build-systems gnu) to discover which
modules to include when extending the used modules via the #:modules argument.
The renaming was automated via the command:
$ git grep -l %gnu-build-system-modules
| xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i
* guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to...
(%default-gnu-imported-modules): ... this.
(%default-modules): Rename to...
(%default-gnu-modules): ... this. Export.
(dist-package, gnu-build, gnu-cross-build): Adjust accordingly.
Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee
| Maxim Cournoyer |