Suppress a warning from grep which causes tests to fail.
Taken from upstream pull request:
https://github.com/aureliojargas/clitest/pull/54
diff --git a/test/inline-match-egrep.sh b/test/inline-match-egrep.sh
--- a/test/inline-match-egrep.sh
+++ b/test/inline-match-egrep.sh
@@ -42,7 +42,7 @@ $ printf ' \t \t\t \n' #=> --egrep ^ $
# egrep regexes. You'll need to test in your system if that's the
# case. I recommend using a literal tab to avoid problems.
-$ printf 'may\tfail' #=> --egrep ^may\tfail$
+$ printf 'may\tfail' #=> --egrep ^may\\tfail$
$ printf 'may\tfail' #=> --egrep ^may[\t]fail$
$ printf 'will\tmatch' #=> --egrep ^will match$
@@ -51,7 +51,7 @@ $ printf 'will\tmatch' #=> --egrep ^will match$
# These tests will fail:
$ printf 'will\nfail' #=> --egrep will.*fail
-$ printf 'will\nfail' #=> --egrep will\nfail
+$ printf 'will\nfail' #=> --egrep will\\nfail
# If one line of a multiline results matches, the test is OK
'/guix/'>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-04-20 | import: Remove Nix importer....This importer has suffered from bitrot and no longer works with current
Nix and Nixpkgs. See <https://bugs.gnu.org/32339> and
<https://bugs.gnu.org/36255>.
* guix/import/snix.scm, guix/scripts/import/nix.scm,
tests/snix.scm: Remove.
* Makefile.am (MODULES, SCM_TESTS): Remove them.
* guix/scripts/import.scm (importers): Remove "nix".
* build-aux/test-env.in: Remove NIXPKGS variable.
* configure.ac: Remove '--with-nixpkgs' option.
* doc/guix.texi (Invoking guix import): Remove bit about "guix import
nix".
* etc/completion/fish/guix.fish: Likewise.
| Ludovic Courtès |
2021-02-17 | scripts: system: Remove 'vm-image' command....Remove the 'vm-image' command that has been superseded by the 'image'
command.
* gnu/system/vm.scm (system-qemu-image): Remove it.
* guix/scripts/system.scm (system-derivation-for-action): Mark 'vm-image'
command as deprecated and use the image API to produce the VM image.
(perform-action, show-help): Adapt accordingly.
* tests/guix-system.sh: Ditto.
* doc/guix.texi (Invoking guix system,
Running Guix in a VM): Ditto.
* etc/completion/fish/guix.fish: Ditto.
* etc/completion/zsh/_guix: Ditto.
| Mathieu Othacehe |