diff --git a/CMakeLists.txt b/CMakeLists.txt index 4022c383b..3202b8b69 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -83,6 +83,7 @@ pkg_check_modules(LIBPULSE libpulse) pkg_check_modules(LIBXML libxml-2.0) pkg_check_modules(SPOTIFY libspotify>=12.1.45) pkg_check_modules(TAGLIB REQUIRED taglib>=1.6) +pkg_check_modules(OPENSSL REQUIRED openssl) if (WIN32) find_package(ZLIB REQUIRED) @@ -381,20 +382,6 @@ if(GMOCK_INCLUDE_DIRS) endif(GTEST_INCLUDE_DIRS) endif(GMOCK_INCLUDE_DIRS) -# Use the system's sha2 if it's available. -find_path(SHA2_INCLUDE_DIRS sha2.h) -find_library(SHA2_LIBRARIES sha2) -if(SHA2_LIBRARIES AND SHA2_INCLUDE_DIRS) - message(STATUS "Using system sha2 library") - set(USE_SYSTEM_SHA2 ON) -else() - message(STATUS "Using builtin sha2 library") - set(USE_SYSTEM_SHA2 OFF) - add_subdirectory(3rdparty/sha2) - set(SHA2_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/sha2) - set(SHA2_LIBRARIES sha2) -endif() - # Use the system libmygpo-qt5 if a recent enough version was found if(LIBMYGPO_QT5_FOUND) set(MYGPOQT5_LIBRARIES ${LIBMYGPO_QT5_LIBRARIES}) diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt index 6e24c9726..104d044d9 100644 --- a/src/CMakeLists.txt +++ b/src/CMakeLists.txt @@ -29,7 +29,6 @@ include_directories(${LIBPROJECTM_INCLUDE_DIRS}) include_directories(${QTSINGLEAPPLICATION_INCLUDE_DIRS}) include_directories(${QTIOCOMPRESSOR_INCLUDE_DIRS}) include_directories(${QXT_INCLUDE_DIRS}) -include_directories(${SHA2_INCLUDE_DIRS}) include_directories(${CHROMAPRINT_INCLUDE_DIRS}) include_directories(${MYGPOQT5_INCLUDE_DIRS}) @@ -1223,7 +1222,7 @@ target_link_libraries(clementine_lib libclementine-common libclementine-tagreader libclementine-remote - ${SHA2_LIBRARIES} + ${OPENSSL_LIBRARIES} ${TAGLIB_LIBRARIES} ${MYGPOQT5_LIBRARIES} ${CHROMAPRINT_LIBRARIES} diff --git a/src/core/utilities.cpp b/src/core/utilities.cpp index ce76f22da..80bf623fb 100644 --- a/src/core/utilities.cpp +++ b/src/core/utilities.cpp @@ -52,7 +52,7 @@ #include "config.h" #include "timeconstants.h" -#include "sha2.h" +#include #if defined(Q_OS_UNIX) #include 0043a2cea12c82710026'>image.scm
AgeCommit message (Expand)Author
2022-09-24system: image: Add wsl2 support....Alex Griffin
2022-09-24system: image: Add tarball support....Alex Griffin
2022-09-24image: Make the operating-system field mandatory....Mathieu Othacehe
2022-09-07image: Use #true and #false....Mathieu Othacehe
2022-09-07image: Use a default size partition value....Mathieu Othacehe
2022-08-31image: Add comments....Mathieu Othacehe
2022-08-30image: Remove an unused field....Mathieu Othacehe
2022-08-30image: Perform more sanitizing....Mathieu Othacehe
2022-07-01image: Add sanitizers for 'format' and 'partition-table-type'....Ludovic Courtès
2022-07-01image: Add default value for partition initializer....Ludovic Courtès
2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/....Josselin Poiret
2021-12-23image: Add a shared-network? field....Mathieu Othacehe
2021-12-23image: Add a shared-store? field....Mathieu Othacehe
2021-11-12image: Support generating GPT images via `partition-table-type`....Ryan Sundberg
2021-10-11gnu: Add platform support....Mathieu Othacehe