Patch downloaded from https://github.com/clementine-player/Clementine/pull/5669 . diff -ruN clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp clementine-1.3.1.565.gd20c2244a/src/core/database.cpp --- clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp 2018-07-07 23:59:24.018540126 +0200 +++ clementine-1.3.1.565.gd20c2244a/src/core/database.cpp 2018-07-08 00:04:47.991551728 +0200 @@ -265,6 +265,17 @@ StaticInit(); { + +#ifdef SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER + // In case sqlite>=3.12 is compiled without -DSQLITE_ENABLE_FTS3_TOKENIZER + // (generally a good idea due to security reasons) the fts3 support should be enabled explicitly. + QVariant v = db.driver()->handle(); + if (v.isValid() && qstrcmp(v.typeName(), "sqlite3*") == 0) { + sqlite3 *handle = *static_cast(v.data()); + if (handle) sqlite3_db_config(handle, SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER, 1, NULL); + } +#endif + QSqlQuery set_fts_tokenizer(db); set_fts_tokenizer.prepare("SELECT fts3_tokenizer(:name, :pointer)"); set_fts_tokenizer.bindValue(":name", "unicode"); d633a8ad1c9f2578be7bbde36ed7ce7'>refslogtreecommitdiff
path: root/gnu/packages/debug.scm
AgeCommit message (Expand)Author
2018-02-22gnu: american-fuzzy-lop: Change custom qemu input....Efraim Flashner
2018-01-16gnu: american-fuzzy-lop: Update to 2.52b....Efraim Flashner
2017-09-20gnu: Use 'modify-phases' syntax....Kei Kebreau
2017-09-04gnu: Put autoconf-related phases immediately after the 'unpack phase....Kei Kebreau
2017-08-17gnu: american-fuzzy-lop: Update to 2.49b....Efraim Flashner
2017-08-17gnu: american-fuzzy-lop: Add support for non-Intel architectures....Efraim Flashner
2017-08-09gnu: stress-make: Patch default shell....Eric Bavier
2017-07-15gnu: Rename (gnu packages qemu) to (gnu packages virtualization)....宋文武
2017-03-15gnu: Use INSTALL-FILE where appropriate....Tobias Geerinckx-Rice
2017-03-15gnu: stress-make: Fix description....Tobias Geerinckx-Rice
2016-11-29gnu: Add zzuf...John Darrington
2016-09-09gnu: c-reduce: Upgrade to 2.5.0....Eric Bavier
2016-09-06gnu: Fix pre-2.7.0 qemu builds....Efraim Flashner
2016-08-13gnu: Add stress-make....Eric Bavier
2016-07-20Revert "gnu: julia: Build with zlib."...Efraim Flashner
2016-07-20gnu: julia: Build with zlib....Efraim Flashner
2016-06-21gnu: Update american-fuzzy-lop to 2.15b....Eric Bavier