Patch downloaded from https://github.com/clementine-player/Clementine/pull/5669 . diff -ruN clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp clementine-1.3.1.565.gd20c2244a/src/core/database.cpp --- clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp 2018-07-07 23:59:24.018540126 +0200 +++ clementine-1.3.1.565.gd20c2244a/src/core/database.cpp 2018-07-08 00:04:47.991551728 +0200 @@ -265,6 +265,17 @@ StaticInit(); { + +#ifdef SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER + // In case sqlite>=3.12 is compiled without -DSQLITE_ENABLE_FTS3_TOKENIZER + // (generally a good idea due to security reasons) the fts3 support should be enabled explicitly. + QVariant v = db.driver()->handle(); + if (v.isValid() && qstrcmp(v.typeName(), "sqlite3*") == 0) { + sqlite3 *handle = *static_cast(v.data()); + if (handle) sqlite3_db_config(handle, SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER, 1, NULL); + } +#endif + QSqlQuery set_fts_tokenizer(db); set_fts_tokenizer.prepare("SELECT fts3_tokenizer(:name, :pointer)"); set_fts_tokenizer.bindValue(":name", "unicode"); 17e02ee3b41dd7aa3a220be50191b6ed6fe9e'>refslogtreecommitdiff
path: root/gnu/packages/openldap.scm
AgeCommit message (Expand)Author
2022-01-21gnu: python-ldap: Update to 3.4.0....* gnu/packages/openldap.scm (python-ldap): Update to 3.4.0. [arguments]: Remove input labels. [inputs]: Change from OPENLDAP to OPENLDAP-2.6. Marius Bakke
2022-01-21gnu: OpenLDAP: Add 2.6.1....* gnu/packages/openldap.scm (openldap-2.6): New variable. Marius Bakke
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès
2021-11-23Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-22gnu: nss-pam-ldapd: Update to 0.9.12....* gnu/packages/openldap.scm (nss-pam-ldapd): Update to 0.9.12. [arguments]: Remove trailing #T. Ricardo Wurmus
2021-10-01gnu: 389-ds-base: Substitute more tool references....* gnu/packages/openldap.scm (389-ds-base)[arguments]: Substitute references to "ip" and "openssl". [inputs]: Add iproute. Ricardo Wurmus
2021-09-30gnu: 389-ds-base: Update to 1.4.4.17....* gnu/packages/openldap.scm (389-ds-base): Update to 1.4.4.17. [source]: Use release tarball from Github. [arguments]: Remove wrapping of readnsstate. Ricardo Wurmus
2021-09-30gnu: 389-ds-base: Restore definition of pythondir....* gnu/packages/openldap.scm (389-ds-base)[arguments]: Import python-version from (guix build python-build-system); define pythondir before using it in fix-install-location-of-python-tools. Ricardo Wurmus