This is modeled after the ia64 support. Aarch64 can be either big endian
or little endian, so we add the case for both.
---
native/fdlibm/ieeefp.h | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/native/fdlibm/ieeefp.h b/native/fdlibm/ieeefp.h
index 1a9740f..73455c0 100644
--- a/native/fdlibm/ieeefp.h
+++ b/native/fdlibm/ieeefp.h
@@ -27,6 +27,14 @@
#endif
#endif
+#ifdef __aarch64__
+#ifdef __BIG_ENDIAN__
+#define __IEEE_BIG_ENDIAN
+#else
+#define __IEEE_LITTLE_ENDIAN
+#endif
+#endif
+
#ifdef __hppa__
#define __IEEE_BIG_ENDIAN
#endif
--
2.16.3
d>
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-05-11 | gnu: home: services: fontutils: Add support for SXML fragments....* gnu/home/services/fontutils.scm (add-fontconfig-config-file): Add
support for adding arbitrary SXML configuration into fonts.conf;
* doc/guix.texi (Fonts Services): Update the documentation.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Andrew Patterson |
2023-01-31 | home: services: fontutils: Add service value....* gnu/home/services/fontutils.scm (add-fontconfig-config-file): Add
support for multiple paths;
(home-fontconfig-service-type): Honor it;
* doc/guix.texi (Fonts Services): Document it.
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
| Giacomo Leidi |