Patch based on changes from https://github.com/llvm/llvm-project/commit/c1fde4fa943fd03a3d40bc5d32b9e0045fd29208 diff --git a/lib/sanitizer_common/scripts/gen_dynamic_list.py b/lib/sanitizer_common/scripts/gen_dynamic_list.py index 5ea2ca1..d7bc287 100755 --- a/lib/sanitizer_common/scripts/gen_dynamic_list.py +++ b/lib/sanitizer_common/scripts/gen_dynamic_list.py @@ -100,7 +100,7 @@ def main(argv): print('global:') result.sort() for f in result: - print(' ' + f.encode('utf-8') + ';') + print(u' %s;' % f) if args.version_list: print('local:') print(' *;') id' value='54edc96c4d85c55feb0f64fdc1919c7d26b6e13b'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/vpn.scm
AgeCommit message (Collapse)Author
2023-09-09services: vpn: Fix broken format string for wireguard dns.Reily Siegel
* gnu/services/vpn.scm (wireguard-configuration-file): Fix broken format string. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2023-07-21services: wireguard: Add a 'configuration' action.Maxim Cournoyer
* gnu/services/vpn.scm (wireguard-shepherd-service) [actions]: New field.
2023-07-21services: wireguard: Clean-up configuration file serializer.Maxim Cournoyer
Previously, the generated config file would contain arbitrary whitespace that made it look ugly. * gnu/services/vpn.scm (<wireguard-configuration>) [dns]: Change default value from #f to '(). (wireguard-configuration-file): Use match-record. Format each line individually, assembling the lines at the end to avoid extraneous white space. * doc/guix.texi (VPN Services): Update doc.
2023-07-21services: wireguard: Implement a dynamic IP monitoring feature.Maxim Cournoyer
* gnu/services/vpn.scm (<wireguard-configuration>) [monitor-ips?, monitor-ips-internal]: New fields. * gnu/services/vpn.scm (define-with-source): New syntax. (wireguard-service-name, strip-port/maybe) (ipv4-address?, ipv6-address?, host-name?) (endpoint-host-names): New procedure. (wireguard-monitoring-jobs): Likewise. (wireguard-service-type): Register it. * tests/services/vpn.scm: New file. * Makefile.am (SCM_TESTS): Register it. * doc/guix.texi (VPN Services): Update doc. Reviewed-by: Bruno Victal <mirai@makinata.eu>
2023-03-03services: vpn: Deprecate 'openvpn-client-service' & 'openvpn-server-service' ↵Bruno Victal
procedures. * doc/guix.texi (VPN Services): Replace 'openvpn-client-service' & 'openvpn-server-service' procedures with their service-type counterparts. * gnu/services/vpn.scm (openvpn-client-service, openvpn-server-service): Deprecate procedure. (openvpn-server-service-type, openvpn-client-service-type): Set default value. Signed-off-by: Ludovic Courtès <ludo@gnu.org>