Age | Commit message (Expand) | Author |
t message (Expand)Author |
2024-06-04 | services: base: Add optional delayed mount of file-systems...Add a mechanism to only require mounting a subset of file-system entries
during early Shepherd initialization. Any file-system with additional Shepherd
service requirements (e.g. networking) is not required to provision
'file-systems.
* gnu/services/base.scm (file-system-shepherd-service): Splice
file-system-requirements into the Shepherd service requirement list.
(file-system-shepherd-services): Provision 'file-system only when file system
services without additional Shepherd requirements are started.
* gnu/system/file-systems.scm (file-system): Add shepherd-requirements field
to the file-system record. This field is used for adding additional Shepherd
requirements to a file-system Shepherd service.
* doc/guix.texi: Add documentation for file-system shepherd-requirements.
Change-Id: If0392db03d48e8820aa53df1df482c12ec72e1a5
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Richard Sent |
2024-05-13 | file-systems: Add "virtiofs" to the list of pseudo file system types....* gnu/system/file-systems.scm (%pseudo-file-system-types): Add "virtiofs"
to the list of pseudo file system types.
Change-Id: Ib1d99127e65f6543c592faec1c54bd0c5eae3ad7
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Massimo Zaniboni |
2023-12-10 | file-systems: Add tracefs to %pseudo-file-system-types....* gnu/system/file-systems.scm (%pseudo-file-system-types): Add tracefs.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Leo Nikkilä |
2023-10-30 | gnu: file-systems: Add xenfs to %pseudo-file-system-types....* gnu/system/file-systems.scm (%pseudo-file-system-types): Add xenfs.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Skyler Ferris |
2023-09-17 | gnu: file-systems: Add variable %base-live-file-systems....* gnu/system/file-systems.scm (%base-live-file-systems): New variable.
* gnu/system/install.scm (installation-os): Use %base-live-file-systems.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Nicolas Graves |
2023-08-08 | file-systems: Use cgroups v2....cgroup v2 is the next generation of the control groups API. This patch
replaces the cgroup v1 file systems with the unified cgroup v2 file
system.
cgroup v2 allows for things like containerd/podman to run rootless
containers and opens guix system up to running things like Kubernetes.
Thanks to Hilton Chain <hako@ultrarare.space> for suggesting the Docker
service change.
* gnu/system/file-systems.scm (%control-groups): Change to a single
"cgroup2" mount point.
* gnu/services/docker.scm (docker-shepherd-service): Trim 'requirement'
field accordingly.
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
| Sam Lockart |