Adjust libsanitizer to ABI change in glibc 2.31.
Adapted to 3.x from this upstream commit:
https://github.com/llvm/llvm-project/commit/947f9692440836dcb8d88b74b69dd379d85974ce
--- a/lib/sanitizer_common/saniniitizer_platform_limits_posix.h.orig 2020-08-11 16:01:32.494882282 +0200 #
+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.h 2020-08-11 16:32:49.711383554 +0200
@@ -176,8 +176,7 @@
unsigned long __unused1;
unsigned long __unused2;
#else
- unsigned short mode;
- unsigned short __pad1;
+ unsigned int mode;
unsigned short __seq;
unsigned short __pad2;
#if defined(__x86_64__) && !defined(_LP64)
--- a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc 2020-08-11 16:01:07.926821829 +0200
+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc.orig 2020-08-11 16:01:03.698811421 +0200
@@ -1056,7 +1056,9 @@
CHECK_SIZE_AND_OFFSET(ipc_perm, gid);
CHECK_SIZE_AND_OFFSET(ipc_perm, cuid);
CHECK_SIZE_AND_OFFSET(ipc_perm, cgid);
+#if !SANITIZER_LINUX || __GLIBC_PREREQ (2, 31)
CHECK_SIZE_AND_OFFSET(ipc_perm, mode);
+#endif
CHECK_TYPE_SIZE(shmid_ds);
CHECK_SIZE_AND_OFFSET(shmid_ds, shm_perm);
3d93bc5008618fb0b9ff26f0e0f4323d18'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2024-12-12 | build: Fix detection of guile-ssh....Fixes <https://issues.guix.gnu.org/74800>.
The check for make-session stopped working after update to 0.18.0. This
commit adds the additional `#:config #f' to skip reading the ssh
configuration, arguably we did not want to do that anyway.
* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.
Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Reported-by: Dariqq <dariqq@posteo.net>
| Tomas Volf |
2024-12-03 | gnu: bootstrap: Add support for x86_64-gnu, aka the 64bit Hurd....On commit:
ec8a5ec15f898e864705e5a5c834532e3fa8d0a4
gnu: make-bootstrap: Update gcc-static to gcc-14, for the 64bit Hurd.
Run:
./pre-inst-env guix build --target=x86_64-gnu bootstrap-tarballs
Producing:
/gnu/store/w1n7bdpn88plcc49h7n0jriaj41sgwx8-bootstrap-tarballs-0/
With guix hash -r:
15cb1xh7s2hhp8s0d81bjnw1759w9sh7ckc9n5jq2f3rqw6z76by
* gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for
x86_64-gnu.
(%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils,
%bootstrap-glibc, %bootstrap-gcc): Add entry for x86_64-gnu.
* guix/packages.scm (%supported-systems, %hurd-systems): Add x86_64-gnu.
(%cuirass-supported-systems): Remove x86_64-gnu.
* guix/utils.scm (target-64bit?): Add x86_64-gnu.
* m4/guix.m4: Add x86_64-gnu as a supported system.
* doc/guix.texi (GNU Distribution): Add x86_64-gnu.
Change-Id: I828159aedb3f66caba98e935083cc3682429f219
| Janneke Nieuwenhuizen |
2023-11-07 | build: Fix spelling in m4 macros....* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Fix spelling of parameter.
(GUIX_CHECK_FILE_NAME_LIMITS): Fix spelling of maximum.
Change-Id: I93c80441393622a4bc06daa475eee13874cca527
| Efraim Flashner |
2023-03-16 | build: Correct guix_system on musl libc distros....* m4/guix.m4 (GUIX_SYSTEM_TYPE): Add linux-musl* case. This prevents
the macro from mis-parsing the host OS, which causes breakage when
building from source.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Antero Mejr |