Search for ASDF configuration files first in user directories, and then in
Guix profiles.
diff -ru a/asdf-3.3.4.lisp b/asdf-3.3.4.lisp
--- a/asdf-3.3.4.lisp 2020-02-14 20:16:22.000000000 +0100
+++ b/asdf-3.3.4.lisp 2020-12-05 11:09:56.066229482 +0100
@@ -12535,10 +12535,15 @@
(find-preferred-file (system-config-pathnames *output-translations-file*)
:direction direction))
(defun user-output-translations-directory-pathname (&key (direction :input))
- (xdg-config-pathname *output-translations-directory* direction))
- (defun system-output-translations-directory-pathname (&key (direction :input))
- (find-preferred-file (system-config-pathnames *output-translations-directory*)
+ (find-preferred-file (list (xdg-config-home *output-translations-directory*))
:direction direction))
+ (defun system-output-translations-directory-pathname (&key (direction :input))
+ `(:output-translations
+ ,@(loop :for dir :in (filter-pathname-set
+ (xdg-config-dirs
+ "common-lisp/asdf-output-translations.conf.d/"))
+ :collect `(:include ,dir))
+ :inherit-configuration))
(defun environment-output-translations ()
(getenv "ASDF_OUTPUT_TRANSLATIONS"))
@@ -12921,10 +12926,15 @@
(find-preferred-file (system-config-pathnames *source-registry-file*)
:direction direction))
(defun user-source-registry-directory (&key (direction :input))
- (xdg-config-pathname *source-registry-directory* direction))
- (defun system-source-registry-directory (&key (direction :input))
- (find-preferred-file (system-config-pathnames *source-registry-directory*)
+ (find-preferred-file (list (xdg-config-home *source-registry-directory*))
:direction direction))
+ (defun system-source-registry-directory (&key (direction :input))
+ `(:source-registry
+ ,@(loop :for dir :in (filter-pathname-set
+ (xdg-config-dirs
+ "common-lisp/source-registry.conf.d/"))
+ :collect `(:include ,dir))
+ :inherit-configuration))
(defun environment-source-registry ()
(getenv "CL_SOURCE_REGISTRY"))
ft'>Commit message (Expand)
Author |
2021-10-09 | home: services: configuration: Support file-like objects....* gnu/home/services/configuration.scm (interpose): Operate only with file-like
objects.
(string-or-gexp?): Delete procedure.
(serialize-string-or-gexp): Rename to 'serialize-file-like'.
(text-config?): Call 'file-like' intead of 'string-or-gexp?'.
* guix/scripts/home/import.scm:
(generate-bash-module+configuration): Don't call slurp-file-gexp.
* gnu/home/services/configuration.scm: Move content ...
* gnu/services/configuration.scm: here.
* gnu/home/services/shells.scm: Delete (gnu home services configuration).
* gnu/home/services/xdg.scm: Same.
* gnu/local.mk: Same.
* tests/guix-home.sh:
Test home-bash-service-type and extension with home-bash-extension.
| Oleg Pykhalov |
2021-10-09 | scripts: home: Make sure profile directory exists....* guix/scripts/home.scm (process-action): Make sure profile directory exists.
| Oleg Pykhalov |
2021-10-09 | Move (gnu home-services) to (gnu home services)....* gnu/home-services.scm (%guix-home-root-directory): Replace
gnu/home-services.scm with "gnu/home/services.scm".
Rename to gnu/home/services.scm.
* gnu/local.mk
(GNU_SYSTEM_MODULES): Rename gnu/home-services.scm to gnu/home/services.scm.
* doc/he-config-bare-bones.scm:
Replace (gnu home-services) with (gnu home services).
* gnu/home.scm: Same.
* gnu/home/services/fontutils.scm: Same.
* gnu/home/services/mcron.scm: Same.
* gnu/home/services/shells.scm: Same.
* gnu/home/services/shepherd.scm: Same.
* gnu/home/services/symlink-manager.scm: Same.
* gnu/home/services/xdg.scm: Same.
* guix/scripts/home.scm: Same.
* guix/self.scm: Same.
| Oleg Pykhalov |
2021-10-08 | gnu: Move (gnu home-services) to (gnu home services)....* gnu/home-services/configuration.scm: Move the content ...
* gnu/home/services/configuration.scm: ... here.
* doc/guix.texi:
Replace (gnu home-services mcron) with (gnu home services mcron).
Replace (gnu home-services) with (gnu home services).
* gnu/home.scm:
Replace (gnu home-services fontutils) with (gnu services fontutils).
Replace (gnu home-services shells) with (gnu home services shells).
Replace (gnu home-services symlink-manager) with
(gnu home services symlink-manager).
Replace (gnu home-services xdg) with (gnu home services xdg).
* gnu/home-services/fontutils.scm: Rename to gnu/services/fontutils.scm.
* gnu/home-services/mcron.scm: Move to gnu/home/services/mcron.scm.
Replace (gnu home-services shepherd) with (gnu home services shepherd).
* gnu/home-services.scm (%service-type-path):
Search home services in "gnu/services".
* gnu/home-services/shells.scm: Replace (gnu home-services configuration) with
(gnu home services configuration).
Rename to gnu/home/services/shells.scm.
Replace (gnu home-services utils) with (gnu home services utils).
* gnu/home-services/shepherd.scm: Move to gnu/home/services/shepherd.scm.
* gnu/home-services/symlink-manager.scm:
Rename to gnu/home/services/symlink-manager.scm.
* gnu/home-services/utils.scm: Rename to gnu/home/services/utils.scm.
* gnu/home-services/xdg.scm: Rename to gnu/home/services/xdg.scm.
* guix/scripts/home/import.scm:
Replace (gnu home-services bash) with (gnu home services bash).
* gnu/home-services.scm: Update documentation string.
* doc/he-config-bare-bones.scm:
Apply new (gnu home-services ...) modules location.
* gnu/local.mk (GNU_SYSTEM_MODULES): Same.
| Oleg Pykhalov |