Taken from Debian, necessary for compilation on mips. Patch to fix integer types problem by Goswin von Brederlow (#258444) --- chmlib-0.39.orig/src/chm_lib.c +++ chmlib-0.39/src/chm_lib.c @@ -56,6 +56,7 @@ #include "lzx.h" +#include #include #include #ifdef CHM_DEBUG @@ -149,22 +150,9 @@ typedef __int64 Int64; typedef unsigned __int64 UInt64; -/* I386, 32-bit, non-Windows */ -/* Sparc */ -/* MIPS */ -/* PPC */ -#elif __i386__ || __sun || __sgi || __ppc__ -typedef unsigned char UChar; -typedef short Int16; -typedef unsigned short UInt16; -typedef long Int32; -typedef unsigned long UInt32; -typedef long long Int64; -typedef unsigned long long UInt64; - /* x86-64 */ /* Note that these may be appropriate for other 64-bit machines. */ -#elif __x86_64__ || __ia64__ +#elif defined(__LP64__) typedef unsigned char UChar; typedef short Int16; typedef unsigned short UInt16; @@ -173,10 +161,18 @@ typedef long Int64; typedef unsigned long UInt64; +/* I386, 32-bit, non-Windows */ +/* Sparc */ +/* MIPS */ +/* PPC */ #else - -/* yielding an error is preferable to yielding incorrect behavior */ -#error "Please define the sized types for your platform in chm_lib.c" +typedef unsigned char UChar; +typedef short Int16; +typedef unsigned short UInt16; +typedef long Int32; +typedef unsigned long UInt32; +typedef long long Int64; +typedef unsigned long long UInt64; #endif /* GCC */ on>
AgeCommit message (Expand)Author
2024-03-10gnu: Remove python-rdflib-jsonld.Arun Isaac
2024-03-10gnu: Remove python-rdflib-5.Arun Isaac
2024-01-16gnu: python-pyrdfa3: Update to 3.6.2.Ricardo Wurmus
2024-01-11gnu: sord: Update to 0.16.16.Ricardo Wurmus
2024-01-11gnu: sord: Enable tests.Brendan Tildesley
2024-01-11gnu: serd: Update to 0.32.0.Ricardo Wurmus
2024-01-11gnu: serd: Enable tests.Brendan Tildesley
2023-05-19gnu: sord: Update to 0.16.14.Ricardo Wurmus
2023-05-19gnu: serd: Update to 0.30.16.Ricardo Wurmus
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice