Taken from Debian, necessary for compilation on mips. Patch to fix integer types problem by Goswin von Brederlow (#258444) --- chmlib-0.39.orig/src/chm_lib.c +++ chmlib-0.39/src/chm_lib.c @@ -56,6 +56,7 @@ #include "lzx.h" +#include #include #include #ifdef CHM_DEBUG @@ -149,22 +150,9 @@ typedef __int64 Int64; typedef unsigned __int64 UInt64; -/* I386, 32-bit, non-Windows */ -/* Sparc */ -/* MIPS */ -/* PPC */ -#elif __i386__ || __sun || __sgi || __ppc__ -typedef unsigned char UChar; -typedef short Int16; -typedef unsigned short UInt16; -typedef long Int32; -typedef unsigned long UInt32; -typedef long long Int64; -typedef unsigned long long UInt64; - /* x86-64 */ /* Note that these may be appropriate for other 64-bit machines. */ -#elif __x86_64__ || __ia64__ +#elif defined(__LP64__) typedef unsigned char UChar; typedef short Int16; typedef unsigned short UInt16; @@ -173,10 +161,18 @@ typedef long Int64; typedef unsigned long UInt64; +/* I386, 32-bit, non-Windows */ +/* Sparc */ +/* MIPS */ +/* PPC */ #else - -/* yielding an error is preferable to yielding incorrect behavior */ -#error "Please define the sized types for your platform in chm_lib.c" +typedef unsigned char UChar; +typedef short Int16; +typedef unsigned short UInt16; +typedef long Int32; +typedef unsigned long UInt32; +typedef long long Int64; +typedef unsigned long long UInt64; #endif /* GCC */ '>range
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-08 20:59:28 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:18 +0100
commit9d613c36de1ea52e745d30bad841b6cdeaca65f4 (patch)
treedbe96f4cb5789e67bf1f51e83cfe132bf3bb90f7 /gnu
parentd94608bc136cc42ea70d676122fa363ae866bcd8 (diff)
downloadguix-9d613c36de1ea52e745d30bad841b6cdeaca65f4.tar.gz
guix-9d613c36de1ea52e745d30bad841b6cdeaca65f4.zip
gnu: node-mersenne: Fix typo in description.
* gnu/packages/node-xyz.scm (node-mersenne)[description]: Use “this” rather than “thix”.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 6db073a164..87892410f9 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -172,7 +172,7 @@ user-land JavaScript.")
(arguments '(#:tests? #f)) ; No tests.
(home-page "http://www.enchantedage.com/node-mersenne")
(synopsis "Node.js module for generating Mersenne Twister random numbers")
- (description "Thix package provides a node.js port of the Mersenne Twister
+ (description "This package provides a node.js port of the Mersenne Twister
random number generator.")
(license license:bsd-3)))