Patch extracted from a set of patches to cross-compile ffmeg and dependencies for mingw-w64.
https://github.com/Warblefly/MultimediaTools-mingw-w64/commit/01e30a17637b67afd65c1e24302f8daf94b19b32#diff-503bd595ad2a49840cc56acdb3432487a20a0acb7981ce83be51fe311216de8f
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 99a69fd..e5ba8a7 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -35,8 +35,6 @@ endif(VA_LIST_IS_ARRAY)
INCLUDE(TestBigEndian)
TEST_BIG_ENDIAN(WORDS_BIGENDIAN)
-TRY_RUN(BITFIELDS_HTOL TEST_DUMMY ${CMAKE_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/test_BITFIELDS_HTOL.c)
-
INCLUDE(CheckIncludeFiles)
#SET(CMAKE_REQUIRED_INCLUDES "/usr/include;/usr/local/include")
diff --git a/include/xconfig.h.in b/include/xconfig.h.in
index c130600..476c00b 100644
--- a/include/xconfig.h.in
+++ b/include/xconfig.h.in
@@ -233,7 +233,11 @@
/* If using network byte order */
#cmakedefine WORDS_BIGENDIAN
/* If high bits come first in structures */
-#cmakedefine BITFIELDS_HTOL
+#ifdef WORDS_BIGENDIAN
+#define BITFIELDS_HTOL
+#else
+#define BITFIELDS_LTOH
+#endif
#define HAVE_C_BIGENDIAN /* Flag that WORDS_BIGENDIAN test was done */
#define HAVE_C_BITFIELDS /* Flag that BITFIELDS_HTOL test was done */
href='/guix/commit/doc/images?id=5c6355ca351e957cdbf6d73b8e24690c599e0a7f'>commitdiff
|
Age | Commit message (Expand) | Author |
2022-05-12 | doc: Add the "Full-source Bootstrap"....* doc/guix.texi (Reduced Binary Seed Bootstrap): Update and rename to...
(Full-Source Bootstrap): ...this.
* doc/images/gcc-core-mesboot0-graph.dot: Regenerate.
| Jan (janneke) Nieuwenhuizen |
2020-05-22 | doc: Update 'Bootstrapping' for further binary seed reduction....* doc/images/gcc-core-mesboot0-graph.dot: New image, replacing
* doc/images/gcc-mesboot0-bag-graph.dot: ... remove file.
* doc/local.mk (DOT_FILES): Update for new image file.
* doc/guix.texi (Reduced Binary Seed Bootstrap): Use it in updated description
of further reduction of the trusted computing base.
| Jan Nieuwenhuizen |
2019-03-14 | Merge branch 'staging' into core-updates | Marius Bakke |
2019-03-13 | doc: Document the graphical installer some more....* doc/guix.texi (Preparing for Installation): Rewrite to specify the two
installation modes.
(Guided Graphical Installation): New node.
(Manual Installation): New node, with the former sections.
(After System Installation): New node.
* doc/images/installer-network.png, doc/images/installer-partitions.png,
doc/images/installer-resume.png: New files.
* doc/local.mk (dist_infoimage_DATA): Add them.
| Ludovic Courtès |
2018-12-16 | doc: Update mesboot graph without bootstrap-guile....* doc/images/gcc-mesboot-bag-graph.dot: Update.
| Jan Nieuwenhuizen |
2018-11-24 | doc: Update for bootstrap-mescc-tools change....* doc/guix.texi (Reduced Binary Seed Bootstrap): Update for
bootstrap-mescc-tools change.
* doc/images/gcc-mesboot-bag-graph.dot: Regenerate.
| Jan Nieuwenhuizen |
2018-09-23 | doc: Describe the Reduced Binary Seed bootstrap....* doc/guix.texi (Reduced Binary Seed Bootstrap): New node.
* doc/images/gcc-mesboot-bag-graph.dot: New file.
* doc/local.mk (DOT_FILES): Add it.
| Jan Nieuwenhuizen |