Taken from debian.
# Description: Disable update check by default.
Index: calibre/src/calibre/gui2/main.py
===================================================================
--- calibre.orig/src/calibre/gui2/main.py 2014-02-02 10:41:28.470954623 +0100
+++ calibre/src/calibre/gui2/main.py 2014-02-02 10:41:56.546954247 +0100
@@ -37,8 +37,8 @@
help=_('Start minimized to system tray.'))
parser.add_option('-v', '--verbose', default=0, action='count',
help=_('Ignored, do not use. Present only for legacy reasons'))
- parser.add_option('--no-update-check', default=False, action='store_true',
- help=_('Do not check for updates'))
+ parser.add_option('--update-check', dest='no_update_check', default=True, action='store_false',
+ help=_('Check for updates'))
parser.add_option('--ignore-plugins', default=False, action='store_true',
help=_('Ignore custom plugins, useful if you installed a plugin'
' that is preventing calibre from starting'))
ix/refs/?id=2365e8435a13c3aa4308e88773de0a0e7b9ffef9'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-05-20 | The #guix channel is hosted by Libera Chat....* README (Contact): Update network name.
* ROADMAP: Likewise.
* doc/contributing.texi (Contributing): Likewise.
* doc/guix.texi (After System Installation): Likewise.
| Tobias Geerinckx-Rice |
2020-10-23 | doc: Update README....* README (Installation): Do not mention installing Guix from Git anymore.
(Building from Git): Add section.
| Maxim Cournoyer |
2020-10-22 | README: Refer to the manual for building from Git....* README (Installing Guix from Guix): Remove section.
(Installation): For installing from Git, refer to the "Building from Git"
section of the manual and suggest using './pre-inst-env guix pull' rather than
'make install' for installing Guix.
| Maxim Cournoyer |
ip'>Fixes <https://bugs.gnu.org/29761>.
Reported by Martin Castillo <castilma@uni-bremen.de>.
* guix/scripts/gc.scm (argument->verify-options): New procedure.
(%options) ["verify"]: Adjust to use it.
* tests/guix-gc.sh: Add test.
Ludovic Courtès |
2017-11-13 | tests: 'guix-gc.sh' passes even when 'out' or 'drv' are defined as env vars....This fixes a test failure exhibited by
fb17a89912c2a3738dae716e30481c11e1c6f0ac whereby assignments to 'out' in
guix-gc.sh would go to the 'out' environment variable, when it exists,
which in turn prevents garbage collection of $out.
* tests/guix-gc.sh: Add 'unset' invocations.
| Ludovic Courtès |