Copied from Debian. From 03a820b173ed1fdef6ff14b4468f5dbc02ff59be Mon Sep 17 00:00:00 2001 From: Heiko Lewin Date: Tue, 15 Dec 2020 16:48:19 +0100 Subject: [PATCH] Fix mask usage in image-compositor [trimmed test case, since not used in Debian build] --- src/cairo-image-compositor.c | 8 ++-- --- cairo-1.16.0.orig/src/cairo-image-compositor.c +++ cairo-1.16.0/src/cairo-image-compositor.c @@ -2601,14 +2601,14 @@ _inplace_src_spans (void *abstract_rende unsigned num_spans) { cairo_image_span_renderer_t *r = abstract_renderer; - uint8_t *m; + uint8_t *m, *base = (uint8_t*)pixman_image_get_data(r->mask); int x0; if (num_spans == 0) return CAIRO_STATUS_SUCCESS; x0 = spans[0].x; - m = r->_buf; + m = base; do { int len = spans[1].x - spans[0].x; if (len >= r->u.composite.run_length && spans[0].coverage == 0xff) { @@ -2646,7 +2646,7 @@ _inplace_src_spans (void *abstract_rende spans[0].x, y, spans[1].x - spans[0].x, h); - m = r->_buf; + m = base; x0 = spans[1].x; } else if (spans[0].coverage == 0x0) { if (spans[0].x != x0) { @@ -2675,7 +2675,7 @@ _inplace_src_spans (void *abstract_rende #endif } - m = r->_buf; + m = base; x0 = spans[1].x; } else { *m++ = spans[0].coverage; nu/installer/services.scm?id=9f391b90faca02ca97c5018d6c095ecdaa1a94a7'>commitdiff
path: root/gnu/installer/services.scm
AgeCommit message (Expand)Author
2022-08-08installer: Add comments and vertical space to the generated config....Ludovic Courtès
2021-12-28installer: Offer 'gpm-service-type' for non-graphical systems....Leo Famulari
2021-12-28installer: Recommend 'ntp-service-type' for non-graphical systems....Leo Famulari
2021-06-30installer: Offer the CUPS printing service....Tobias Geerinckx-Rice
2021-06-23installer: Remove unused procedure....Tobias Geerinckx-Rice
2020-12-11Revert "services: openssh: Warn about 'password-authentication?' default."...Ludovic Courtès
2020-12-07services: openssh: Warn about 'password-authentication?' default....Ludovic Courtès
2020-10-13installer: Add Emacs EXWM desktop environment....Jan (janneke) Nieuwenhuizen