Copied from Debian. From: Carlos Garcia Campos Date: Mon, 19 Nov 2018 12:33:07 +0100 Subject: ft: Use FT_Done_MM_Var instead of free when available in cairo_ft_apply_variations Fixes a crash when using freetype >= 2.9 [This is considered to be security-sensitive because WebKitGTK+ sets its own memory allocator, which is not compatible with system free(), making this a remotely triggerable denial of service or memory corruption.] Origin: upstream, commit:90e85c2493fdfa3551f202ff10282463f1e36645 Bug: https://gitlab.freedesktop.org/cairo/cairo/merge_requests/5 Bug-Debian: https://bugs.debian.org/916389 Bug-CVE: CVE-2018-19876 --- src/cairo-ft-font.c | 4 ++++ 1 file changed, 4 insertions(+) diff --git a/src/cairo-ft-font.c b/src/cairo-ft-font.c index 325dd61..981973f 100644 --- a/src/cairo-ft-font.c +++ b/src/cairo-ft-font.c @@ -2393,7 +2393,11 @@ skip: done: free (coords); free (current_coords); +#if HAVE_FT_DONE_MM_VAR + FT_Done_MM_Var (face->glyph->library, ft_mm_var); +#else free (ft_mm_var); +#endif } } href='/guix/about/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/getmail.scm
AgeCommit message (Collapse)Author
2020-01-30services: getmail: Fix spelling of "address".Vagrant Cascadian
* gnu/services/getmail (getmail-retriever-configuration): Fix typo.
2020-01-20services: getmail: Adjust a couple of default configuration values.Christopher Baines
Change the message-log-syslog and message-log-verbose configuration values to match the Getmail defaults. * gnu/services/getmail.scm (getmail-options-configuration): Change defaults for message-log-syslog and message-log-verbose * doc/guix.texi (Mail Services): Update the Getmail documentation accordingly.
2020-01-20services: getmail: Fix some configuration documentation strings.Christopher Baines
* gnu/services/getmail.scm (getmail-retriever-configuration): Specify proper documentation strings for some of the fields. * doc/guix.texi (Mail Services): Update the documentation accordingly.
2020-01-20services: getmail: Fix stopping the shepherd service.Christopher Baines
* gnu/services/getmail.scm (getmail-shepherd-services): Add a stop component to the shepherd services.
2019-10-18Fix documentation of delete_after in the getmail service.Florian Pelz
* doc/guix.texi (Getmail service): Remove the word `not'. * gnu/services/getmail.scm (getmail-options-configuration): Ditto.
2019-05-31services: Add getmail.Christopher Baines
Getmail is a mail retriever written in Python, this commit adds a service-type to run getmail. I'm looking at this, as it's a convinient way of getting mailing list messages in to Patchwork. I initially tried putting this in the (gnu services mail) module, but due to also trying to use the define-configuration pattern, it conflicted with the dovecot service. * gnu/services/getmail.scm: New file. * gnu/local.mk: Add it. * gnu/tests/mail.scm (%getmail-os, %test-getmail): New variables. (run-getmail-test): New procedure.