Restore compatibility with newer version of base16-bytestring. Taken from https://raw.githubusercontent.com/archlinux/svntogit-community/packages/trunk/cabal-install-base16-bytestring1.0.patch diff --git a/Distribution/Client/HashValue.hs b/Distribution/Client/HashValue.hs index 54b8aee9e..11e647c1c 100644 --- a/Distribution/Client/HashValue.hs +++ b/Distribution/Client/HashValue.hs @@ -1,3 +1,4 @@ +{-# LANGUAGE CPP #-} {-# LANGUAGE DeriveDataTypeable #-} {-# LANGUAGE DeriveGeneric #-} module Distribution.Client.HashValue ( @@ -72,10 +73,14 @@ hashFromTUF (Sec.Hash hashstr) = --TODO: [code cleanup] either we should get TUF to use raw bytestrings or -- perhaps we should also just use a base16 string as the internal rep. case Base16.decode (BS.pack hashstr) of +#if MIN_VERSION_base16_bytestring(1,0,0) + Right hash -> HashValue hash + Left _ -> error "hashFromTUF: cannot decode base16" +#else (hash, trailing) | not (BS.null hash) && BS.null trailing -> HashValue hash _ -> error "hashFromTUF: cannot decode base16 hash" - +#endif -- | Truncate a 32 byte SHA256 hash to -- s='active' href='/guix/log/gnu/packages/syndication.scm'>logtreecommitdiff
path: root/gnu/packages/syndication.scm
AgeCommit message (Expand)Author
2018-04-02gnu: newsboat: Update to 2.11.1....Marius Bakke
2018-03-25gnu: newsboat: Update to 2.11....Marius Bakke
2018-01-11gnu: newsbeuter: Deprecate in favour of newsboat....Tobias Geerinckx-Rice
2018-01-04gnu: newsboat: Update to 2.10.2....Tobias Geerinckx-Rice
2018-01-04gnu: newsbeuter, newsboat: Correct licence....Tobias Geerinckx-Rice
2018-01-04gnu: json-c: Update to 0.13....Tobias Geerinckx-Rice
2017-10-29gnu: Add newsboat....Efraim Flashner
2017-09-18gnu: newsbeuter: Fix CVE-2017-14500....Efraim Flashner
2017-08-18gnu: newsbeuter: Fix CVE-2017-12904....Leo Famulari