Restore compatibility with newer version of base16-bytestring. Taken from https://raw.githubusercontent.com/archlinux/svntogit-community/packages/trunk/cabal-install-base16-bytestring1.0.patch diff --git a/Distribution/Client/HashValue.hs b/Distribution/Client/HashValue.hs index 54b8aee9e..11e647c1c 100644 --- a/Distribution/Client/HashValue.hs +++ b/Distribution/Client/HashValue.hs @@ -1,3 +1,4 @@ +{-# LANGUAGE CPP #-} {-# LANGUAGE DeriveDataTypeable #-} {-# LANGUAGE DeriveGeneric #-} module Distribution.Client.HashValue ( @@ -72,10 +73,14 @@ hashFromTUF (Sec.Hash hashstr) = --TODO: [code cleanup] either we should get TUF to use raw bytestrings or -- perhaps we should also just use a base16 string as the internal rep. case Base16.decode (BS.pack hashstr) of +#if MIN_VERSION_base16_bytestring(1,0,0) + Right hash -> HashValue hash + Left _ -> error "hashFromTUF: cannot decode base16" +#else (hash, trailing) | not (BS.null hash) && BS.null trailing -> HashValue hash _ -> error "hashFromTUF: cannot decode base16 hash" - +#endif -- | Truncate a 32 byte SHA256 hash to -- refslogtreecommitdiff
path: root/tests/services.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-19 23:59:22 -0400
committerLeo Famulari <leo@famulari.name>2016-07-20 00:01:39 -0400
commit5d4c90ae02f1e0b42d575bba2d828d63aaf79be5 (patch)
treeb5e38d9b402eb88cacedd27e469baca57fbe9034 /tests/services.scm
parent91f9f33a195b20a7b0501da201cec45ff7e9c558 (diff)
downloadguix-5d4c90ae02f1e0b42d575bba2d828d63aaf79be5.tar.gz
guix-5d4c90ae02f1e0b42d575bba2d828d63aaf79be5.zip
gnu: gnutls: Update to 3.5.2.
* gnu/packages/tls.scm (gnutls): Update to 3.5.2. [native-inputs]: Add net-tools.
Diffstat (limited to 'tests/services.scm')
0 files changed, 0 insertions, 0 deletions