Skeleton status files are installed read-only. When copying to the config dir
upon initialization, make sure they end up writable.
--- byobu-5.127/usr/bin/byobu-janitor.in
+++ byobu-5.127/usr/bin/byobu-janitor.in
@@ -82,6 +82,7 @@
if [ ! -r "$BYOBU_CONFIG_DIR/$f" ]; then
# Copy from skeleton, if possible
cp -f "$BYOBU_PREFIX/share/$PKG/status/$f" "$BYOBU_CONFIG_DIR/$f"
+ chmod +w "$BYOBU_CONFIG_DIR/$f"
fi
done
>
|
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-04-17 | gnu: python-jedi: Fix test failure on some file systems....Reported by sirgazil on #guix.
* gnu/packages/patches/python-jedi-sort-project-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python-xyz.scm (python-jedi)[source](patches): Add it.
[arguments]: Run tests more verbosely while at it.
| Marius Bakke |