Age | Commit message (Expand) | Author |
2024-08-31 | gnu: python-3.10: Ungraft removing bundled cacert.pem....* gnu/packages/python.scm (python-3.10): Rename phase
"remove-windows-binaries" to "remove-vendored-wheel-content", and use it to
also remove "cacert.pem". Ungraft.
(python-3.10/fixed): Remove variable.
Change-Id: I0a1a5c7f597ef6e14ea165ccded9aa473c6d9122
| Josselin Poiret |
2024-08-31 | gnu: python: Add libxcrypt dependency....* gnu/packages/python.scm (python-2.7): Add libxcrypt dependency.
Change-Id: I23d99900fd6bbd2f9a88a3efe0c8deac01ef160f
| Josselin Poiret |
2024-08-31 | gnu: python: Make the build reproducible....While Python build was reproducible on a single machine, once multiple file
systems entered the picture, it was no longer true. The solution adopted by
the upstream (and Debian) was cherry-picked.
More info: <https://github.com/python/cpython/pull/8226>.
* gnu/packages/python.scm (python-3.10) [source]: Apply reproducibility patch.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I0273dc0f8511a7acdcc2b462a26cc29a9756c801
| Tomas Volf |
2024-04-26 | gnu: python-3.12: Enable loadable sqlite extensions....This change makes it possible to load sqlite extensions with
import sqlite3
con = sqlite3.connect(":memory:")
con.enable_load_extension(True)
con.load_extension(path_to_extension)
* gnu/packages/python.scm (python-3.12)[arguments]: Add
--enable-loadable-sqlite-extensions to configure-flags.
Change-Id: I4fb0a5482c96a12a71c88bc48fffc4c3abe78544
Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
| Felix Gruber |
2024-04-07 | gnu: python: Use system SSL certificates....* gnu/packages/python.scm (python)[replacement]: New field.
(python/fixed): Provide a python with a patched python-certifi which
only offers to use the system's SSL certificates.
Change-Id: Ic5bcfb6b32282a7e0628232b1dc4cd60f3f2da52
| Efraim Flashner |
2024-03-10 | gnu: python-next: Skip another test....* gnu/packages/python.scm (python-next)[arguments]: Skip another test
which fails on slow machines.
Change-Id: I777aa346c674604a22dc0be0b319f5df02e0ab3b
| Efraim Flashner |
2024-03-09 | gnu: Add python-3.12 and python-next....* gnu/packages/python.scm (python-3.12, python-next): New variables.
* gnu/packages/patches/python-3.12-fix-tests.patch: New file.
Change-Id: Ie393b732a8863569578e72e62603b75a1655a34e
Signed-off-by: Tanguy Le Carrour <tanguy@bioneland.org>
Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
| Tanguy Le Carrour |